Issue loading GRBL 1.1 from 0.9g on CM board v2.2

Hello, its been a while since I used my machine and I noted that there is a new version of CM and CC. I downloaded both of them and loaded CM on the computer attached to the Shapeoko 3. It told me I needed GRBL 1.1 to run CM 4 .

I downloaded the updater and ran it. It said to hold the z limit switch and press okay. I did that as well. 30 or so seconds later it told me I had released the Z switch and the upload failed. I checked and I was holding the right switch. I then tried the X and Y in case something was crossed. I then removed the limit switches from the board and shorted the Z pins manually. Still not working.

I thought maybe because im on too old a version of GRBL so I tried XLoader and an 0.9j hex file. It just hangs.

After reading some I found people saying that they had the issue and it was because there was no bootloader.

So my question is, how do I install a bootloader? or if you know the answer to the grand question how do I get GRBL 1.1 on my CM 2.2 board ?

Thanks in advance.


To install the bootloader you’ll need a programmer — it’s my understanding that a second Arduino if you have one can be so programmed, if not, it’s a specialized piece of equipment.

One other thing to try is to compile Grbl using the Arduino SDK and flash using that.

If you continue to have troubles, please contact us at and we’ll do our best to help you sort this out.

Thanks, yeah it seems like I will need to install a bootloader, as the machine is working well on 0.9g I may just hold off on upgrading.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.