Issues with spliting roughing and finish code

Ok so i ran a Long rough pass last night, just the rough pass code. Then this morning i go get the finish pass code and set all my zero’s just like before. When it starts running the bit is about .250 above the material. I went and set my zero to the first level down and it is still about .125 above. My finish pass is only.0100 so i dont have allot of room to mess with. Normally i run the code start to finish because i have a bitsetter, but because of time i just ran the rough, then today i was going to finish…

So you zeroed Z (only) manually after the roughing pass yesterday + bit change today? Did you use the BitSetter tool change commands, and only swap tools after the first bit prompt at machine initialization or after zeroing?

I assume you didn’t make any oopsies on zeroing to stock top vs bottom, but what reference surface are you using for your zero now that the surface is partially machined?

So when the rough finished last night i shut everything down, got up to start the finish code and let the bit setter do its thing then i put in the next bit and verified that x and y zero was correct and then reset z zero.

Any particular reason to reset Z zero since you have a BitSetter already? It should have handled the tool height difference, and remembered the Z from last night.

that was what i thought, but because it was 2 different jobs i verified it.

I just dont get it, before the bitsetter s few months ago, i used to split the files and had no issues. this is one of the first i have split. i just verified my x,y,z and they are spot on, but the bit it still .250 above the wood.

The rapid to current X/Y/Z has a Z offset of 6mm which is close to 0.25", but I’m not sure how that would come into play if you literally touched the bit down to the surface and clicked re-zero.

exactly, i did a zero touched it down and made sure it was zero on the screen.

Maybe should be worded differently, but I think you’re going to need professional help :slight_smile:

The second zero you did leading to a 0.125" offset is interesting, but may be a red herring.

@WillAdams ideas?

Post a .c2d file, generated G-Code, and step-by-step notes on how you are securing your stock and setting zero relative to it and we’ll do our best to work through this with you.

my stock was secured yesterday with screws to the waist board, I ran the roughing pass yesterday, i pen create motion and loaded the finish gcode and then validated my zero, i changed to the 1/16th bit and set z zero and pressed start. here is the c2d file and the gcode. i tried to upload the finish nc file but it is too big.
Manoply_board.c2d (83.6 KB) (833.9 KB)

i normally do one file with all gcode as i have a bitsetter, but because of time i split this one up.

I think this is because you changed the bit and didn’t measure it again before zeroing.

That is, you let the existing bit get BitSetter’d, then changed it for a new bit without hitting “change tool”, and then manually zeroed the replacement bit.

I imagine CM and the machine think you zeroed it with the old bit, and consequently that the stock is in a different place wrt Z to where it physically is.

1 Like

Good thought but the bit hit the bitsetter on initialization then i zeroed and then i started the file and it hit the bitsetter again. I also shut everything down and rebooted everything and then did it again.

It’s the second hitting of the bitsetter, when you start the file, that causes the problem.

When you initialized, it hit the BitSetter and measured the bit and got a notion of where the end of the bit was.

You then invalidated that notion of the end of the bit by replacing the bit.

Then, when you zeroed the stock, it thought that it was zeroing it with the end of the OLD bit.

When you start the job, it measured the bit, and thought “ahh… there’s a difference between the bit and the bit I measured last time… let me apply that offset to the Z zero before I run the job”.

So… never ever change the bit unless prompted to by Carbide Motion.

1 Like

Is the x set to the top of the stock or the bottom? I know it sounds dumb but I have had it happen once and I thought I was losing my mind after looking at it over and over again for 30 minutes.

I only change the bit when it asks…and i changed the bit when CM told me what bit it wanted. On initialazation it asks for a bit so i just put in the bit it was going to use for the file.

i mostly set x,y,z to the top, and this one is set for the top.

Then I misunderstood this:

This sounded like you let the bitsetter measure the old bit, then you replaced the bit and set the zero. Which would have caused your issues.