JTech 4.2 W Laser Power Issue

I currently have a JTech 4.2 W laser hooked up to a Shapeoko XXL.
However, every time the Shapeoko is turned off at the switch, the laser will not turn on correctly without unplugging and then re-plugging the laser’s input cable to the power board.

I’m wondering if anyone has experienced this issue. I’ve checked the wiring and compared it to the installation directions, but I do not see any errors.

Also, the laser, even at full power, does not seem to be operating as powerfully as it should compared to JTech’s 4.2 W examples, and my LightBurn values were set up remotely with Jay from JTech. It takes several passes, using similar material at the same power/speed, to achieve the same results.

I’m wondering if the 2 issues are related or if the laser is just out of focus.
Thanks in advance for any suggestions.

Hey Sara,
I went down into my basement shop to mess with my JTech 2.8W setup a little and there are times where I don’t use my laser for an extended period of time and when I go back to turn it on I have to press the red reset button on the JTech Driver. When I went to go turn on the laser, I had to press the reset button initially; but then I tried turning the Shapeoko on and off and it didn’t trip the reset, so I’m not entirely sure what causes that. I don’t seem to have the same issue of needing to unplug/plug anything. Are you unplugging/plugging the input cable at the Carbide board or at the JTech Driver? When you’re turning the Shapeoko off and on, the laser requires unplugging/plugging every single time without fail?

When you say, “the laser will not turn on correctly” are you saying it doesn’t turn on at all until unplug/plug back in or it turns on and doesn’t have full function? I understand you checked your wiring, but you still could post pictures of your wiring/boards for an extra set of eyes just in case something may jump out at someone else. I’m wondering if there are connector issues that re-establish a good connection when you plug back in.

As far as your power issues, I’d double check your LightBurn settings and confirm that GRBL setting $30 = 1000 because that would directly affect power output. If Max Spindle RPM ($30) is set correctly at 1000 then I would start to look at focusing your laser to confirm that’s good. Before you double check focus you can also confirm the lens is clean (laser off obviously - sorry had to throw that in there). If your power settings are ok and your focus is good then you could look into confirming voltage output at the Carbide board PWM, I believe it should be 5v max output. Another thing to note is smoke extraction while using the laser, do you have a fan mounted on top of your laser; too much smoke could also inhibit good engraving.

Anyways, hope some of this helps you and you’re able to get to the bottom of all of this.


Adding to @RoughDraft40’s excellent reply, about that $30 thing: the key point is that whatever value you have in $30 on the Shapeoko/GRBL side (it’s probably 1000, that’s the default value on Shapeokos) should match what you have defined in LightBurn in the “S-Value max” (bottom right below):


If there is a mismatch, it could easily explain why “100%” in LightBurn does not translate to 100% power at the laser.

I remember when I first installed LightBurn, the S-Value was set to “255” by default (which would result in 100% setting producing only ~25% power at the laser)


Ah that is an important detail - thanks, Julien!

1 Like

Thank you both for taking the time to offer feedback. I realize I need to take a picture of my control board to better explain my issue, but I won’t be able to get into my classroom for a few. However, to answer one of your questions, the laser will not power on at all unless I unplug the small, power cable and plug it back in. Once I disconnected and reconnect the cable, it turns on as normal. Here’s the best comparison image I could find to explain which cable I’m referring to. It connects to the PWM Signal and GND Signal, two pin header:

I will check my software as well and take screenshots of my settings. I had Jay, from JTech, help me set it up remotely. I recall going over the GRBL setting $30 = 1000, but I will check to see if it somehow changed. I updated my LightBurn software when we purchased the camera add-on, so maybe that could have altered it.

Thanks again for your help!

1 Like

Hey Sara,

Can you confirm if it works if you press the reset button after turning the Shapeoko power supply back on?

The Jtech controller has a safety feature that if it detects a “power outage”, it will not turn back on until it is manually reset:

Did you maybe plug the laser and the shapeoko on the same plug and turn both off ?
I would not be surprised if pushing the reset button when this situation happens lets the controller starts up normally.

In my setup, I have leveraged the safety interlock connector to wire a switch , and toggling that switch is required to enable the laser (which I think is a nice additional layer of safety)


Both the laser and the Shapeoko are plugged into a power strip/surge protector. It makes sense now that when the power strip has been toggled off, the laser would need to be reset.

I’ll have to test out this theory when I’m back in my classroom, but I think you’ve solved the mystery.

Thank you!


This makes a lot of sense for me. I had recently tripped my power strip so that would explain why I had to reset my JTech driver.

Sara, for you, have you ever tried depressing the reset button on the JTech driver versus pulling the Input cable from the Carbide board?

1 Like

Very good post. Those where all the things I was going to say.

My laser is the 7.2W and the start up process is a bit different. Three steps, with some safety features.

Make sure that your Shapeoko and Laser are on before booting Lightburn up. There is a procedure on how to start it up. If done out of sequence you will have errors.

1 Like

I may have tried using the reset button, but it didn’t appear to be the issue at the time. Now that I have a better idea of the sequence related to problem, I’ll check to see if that works instead of disconnecting and reconnecting the cable.

This topic was automatically closed after 30 days. New replies are no longer allowed.