Leaving Islands Behind when pocketing

Im new to CNC and I have been trying to stumble my way through learning by watching videos, reading the forum, and just plain trial and error.

I have what seems like it should be a very simple task and that is to pocket out an area while leaving some islands untouched. The problem is that the pocket operation wants to pocket out the entire shape. Ive seen some other tutorials on this but they are seem to involve v carving or far more complex operations. Ive uploaded the .c2d file below. What i need to do is pocket the inside of the crown (and all the other elements too) while leaving the circles inside untouched. I converted this file to an svg from a png using inkscape.

I know this topic has been brought up before but nothing I am trying works. I would really appreciate any asistance.

crown.c2d (1.6 MB)

two options (I am using the beta version so it might not open in your CC)
Option 1: Just a plain pocketing… this worked if I just selected ALL elements
option1.c2d (1.6 MB)

Option 2: Advancted V-carve. The benefit is that this gives you sharper points, the downside is that your crown hits a worst case behavior in CC’s algorithm and the cutting time is very long
option2.c2d (1.6 MB)


Select the geometry for the islands as well, please see:

1 Like

btw Carbide create works with the “Odd / Even” rule within a selection.
Basically if you would go from left to right (or up down or … well any direction), any time you cross a line, it will switch from “cut out” to “do not cut” and back.
So 1 line crossed - cut out
2 lines crossed - no cut
3 lines crossed - cut out
4 lines crossed - no cut

this applies only to what you selected, so in your case, if you also select the parts you do not want cut, those will be the “2 lines crossed” case and will not be cut


Such rapid help. For some reason, none of that worked until i closed out and restarted CC. But I restarted and it worked just like it should. Thank you all so much!