Limit Switch Homing Error?

(Jason Hunter) #1

I had my Shapeoko XXL up and running great for a couple of months. There was a mold outbreak in my shop and I had to disassemble the Shapeoko to clear the mold and renovate to prevent more in the future. I reassembled the machine and I get Error (37): Limit Switch Error (X) while the X and Z carriage are homing. Then, during the Y homing it pops up with Error (38): Homing Cycle Failed Error (39) GRBL ERROR: Homing Failed, pull off didn’t clear.

With only 2 months or so under my belt, I have no clue as to what is causing the error. Can someone please help with any advice on how to resolve this?

0 Likes

(William Adams) #2

We have a basic page on troubleshooting the homing switches at: https://docs.carbide3d.com/software-faq/home-switch-troubleshooting/

Make sure that the switches aren’t stuck, that the machine isn’t on them when you power it up, and that when pressed they light up the matching light on the controller, when released the light goes off, and that the machine can mechanically close each switch before reaching the end of travel on each axis.

Let us know what you find out and what you’ve tried at support@carbide3d.com and we’ll do our best to help get you homing again.

0 Likes

(Neil Ferreri) #3

Are your connections mixed up? It should home Z first, then X & Y together.

1 Like

(Jason Hunter) #4

It homes Z, then moves the carriage slightly to the left, away from the direction it should go. The 1st error pops up during the movements, with the final errors popping at the end. The carriage moves less than an inch.

Sorry for the late reply, took a long-awaited vacation :slight_smile:

0 Likes