Link to Grbl Updater broken

Is there another way to get the Grbl Updater package? My machine has been stored from a move and after updating to the latest versions of Motion and Create I get an error that grbl 1.1 is required, I have 0.9. My machine is an original Shapeoko 3 with a XL upgrade. The board is version 2.2. Help please

Drop a mail to support@carbide3d.com and they’ll take care of that

1 Like

I got this from carbide support recently - the link still works:

It seems there is some work taking place on our servers.
Sorry about that, in the mean time yo can get it here:

I found the links earlier today as I needed them myself:

(Though I use Linux so they weren’t any use :’( )

Ok thanks got the Updater and tried to run it. It ran to a point then failed saying to not release the z-axis switch. Retried this 3 times and failed on all attempts. Pulled and tested the switch for function and continuity. All good, ran again and failed again. Pulled the switch and bridged with a jumper, again failed. I went back to the build instructions and checked the board visually. The instructions indicated there would be 4 posts left unused. My board has 6. My board is version 2.2. It has besides the 3 axis limits an estop, probe and feed hold. I’m stuck, anybody got suggestions

Hi @atrest,

I suggest you contact support@carbide3d.com, they should help you figure out the specifics for a v2.2 board.

In the meantime, this thread may help a bit ?

My geeky self would have tried to flash the controller using the Arduino IDE, but it’s only easy if you are familiar with that environment. If you end up going the Arduino way, @neilferreri or myself could help you, but I still recommend you first check with support.

(I assume you double-checked that the Z switch is plugged in the right place ?)

1 Like