Lots of issues with my Nomad since switching to CM v2

Issues that have cropped up on my Nomad since I switched to Carbide Motion V2. Windows 6, 64 bit OS.

I also started using VCarvePro and I’m using “GRBL inch” post processor.

It worked fine for a while
All the sudden the rapids for X and Y reversed. Jog moved axes in the correct directions for rapids moves went opposite and hit limits.

The first time the rapids reversed I tried rebooting the computer and cycling power on the Nomad which didn’t help.

I reinstalled CM and things went back to normal.

Later the problem reappeared. I tried reinstalling CM and that hasn’t helped either. I am able to run a job and everything worked as long as I didn’t try to use the “rapids” screen.

I just installed the “older version” of CM listed on the C3D website but it still says Build 366 which is the same as the version listed at the top of the page for the most current version. Everything, including rapids, is working normally now.

Any ideas what’s going on?

Issue #2 is that it seems that the z scaling is sometimes off. When I load a part then run it it will plunge way too deep. I can

Seems to be working fine again after reinstalling it the second time. Good thing I guess.