'Machine Controller Restarted Unexpectedly...' Error

Edit, solved by following Will’s steps + clearing the rail + reverting to an older build

I hadn’t used my machine in a little while, but I’m getting back into it.

Just downloaded the latest version of Carbide Motion (Build 551, released March 15), ran a few test cuts - the cuts themselves ran fine outside of a couple small issues with the speed of the machine.

I fine tuned everything, loaded up the actual non-wasteable material I’m using aaaaaand…the depth of cut was extremely shallow (far shallower than the zero that I’d set). I stopped the cut, the SO3 performed its normal action of raising the spindle out of the way. It hit the top of the Z axis and then started traveling back down, despite no command to do so. I immediately cut power to the machine to prevent damage to the endmill. I looked at my laptop to and was greeted with the following error:

“Machine controller restarted unexpectedly and may be in an undefined state” + another error stating “Cycle Aborted”


(screenshot taken after I’d disconnected my laptop from the SO3)

When I powered up the machine and ran the initialization process, the same error happened, except this time it was a terrible chattering noise after the machine had translated all the way across the X axis.

Any ideas on what I should do?

Power everything down and wait a bit, power up following the sequence described in:

Let us know what you find out at support@carbide3d.com and we’ll do our best to assist.

First, the Z axis is the router up and down.
Second, the X axis travels left and right.
Third, the Y axis travels front to back.

Now, can you explain again what happened? Thanks.

Now, can you explain again what happened? Thanks.

:man_facepalming:

You’re right. Like I said, it’s been a while since I’ve used it.

Power everything down and wait a bit, power up following the sequence described in:

Done. I also reverted to build 542, seems like it cleared the error. I also discovered that the chattering was due to the nut that holds the X axis probe coming loose and sitting on the rail in the path of the v-wheel.

Feel real, real stupid at the moment.

There is no need for feeling stupid. Pencils have erasers for a purpose. Somewhere on the site is an operational checklist. Find that and use it to get your feet back on the ground.

The machine operating checklist is at:

1 Like

Thanks! I remember coming across this at some point a couple months ago but I couldn’t remember where I saw it.

How did you revert back to the previous version. I am having the same issues. I can run my machine without issue with open builds software but prefer carbide and would really like it to work. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.