Machine parameters are invalid when measuring tool

I have and I still have to hear from them. A bit disappointing.

Hmm have you tried giving them a call. They have always been very helpfull with me and my friend BlackJack and I’m in New Zealand at the bottom of the world!

I decided to ignore the errors and what I think is malfunctioning of Carbide Motion. I went ahead and could finish my first project. I"ll post a picture when the lighting conditions are better.

Well that’s sort of good then.

Since support hasn’t contacted me yet, this is a video of my troubles:

I would cycle power on the Nomad and reconnect with Carbide motion.
Here’s the steps:
Power off the Nomad.
Close carbide motion.
Remove USB cable.
Power on Nomad
Reconnect USB
Open Carbide motion and connect.

The video is very helpful,
Thank you for your patience.

1 Like

I followed the procedure and it changes nothing.
I don’t think this is related, but when I was installing CM on Windows 10, I got a firewall pop-up telling me to Allow Carbide to communicate on these networks, I clcked Cancel.
I still get the same “Machine parameters are invalid” after tool measurement. And of course, fast positioning doesn’t work. Even if I can jog the machine manually, I want to ged rid of these messages and be able to do fast positioning. Any more ideas?

You should allow all the carbide3d software install requests. Its not clear to me if you did try reinstalling with all permissions. Can you post your settings window in carbide motion?

The thing is that when I reinstall, I don’t get the firewall question anymore. I imagine that even after an uninstall there are things floating around in configuration files and the registry. I don’t use Windows much, so I wouldn’t know.

Here are my settings:

Try control panel/windows firewall and allow it

Thank you Mark, that worked. I allowed CM access to all networks. I reinstalled the program and the problem persists…

If Carbide3d Support just connected to my computer, we might sort this out more quickly.

Connect the nomad, then open a log (settings > log), then hit the MDI button. In the text field type $# and hit send. The log will populate with machine data. Paste it here so we can take a look at the parameters.

Aha. There’s a wrong value in the G59 field. Open a log again, and in the MDI type the following (you can copy/paste), including the forward slash:

/G10L2P6X-123.815Y-107.850Z-127.000 and hit send. Verify that the G59 shows -123.815, -107.850, -127.000 in the log. Do a homing routine again and the Invalid Parameters message should be gone.

1 Like

Phew!! Finally, that did it. Now Rapid positioning is working. Thanks Jorge for your help.


I received my nomad today and I ot this message too. Tried to enter $# as suggested anf then /G10L2P6X-123.815Y-107.850Z-127.000 but nothing seems to happen when I lick send on either occassion. Can someone help please?

Could you please go through step-by-step:

  • what you did (and on the basis of what documentation)
  • what you expected to happen
  • what actually happened

I am going through set up.

  1. connect usb
    2.power up nomad
  2. start up carbide motion
  3. connect cutter
  4. load 1st tutorial (wrench)
  5. Click Jog
  6. Begin homing
  7. Click to measure tool
  8. Machine parameters invalid message displayed

If I try and move the cutter to the lower left-hand corner of the stock, I can only job the machine a few moves and then it stops responding.

I searched the forum for previous issues and it was suggested that I go to MDI>$# and send to check G59 value and then cut and paste /G10L2P6X-123.815Y-107.850Z-127.000and send. nothing happens when I click send either time


Not sure if this screenshot helps

Very disappointed here. Can support please come back to me please? So far I haven’t been able to start the first tutorial!