Machine stops / cutter not responding

(Peter H) #1

Yesterday I did a project which I created with Fusion 360. I tried to create a ring from beechwood, but the result was very bad. So I did the same project with CC (413) because I thought that I did something wrong selecting speed and feed.
Today I try to machine this project but run only in trouble.
First the machine stops in the middle (line 3095).
After a power cycle of the machine and a restart of CM (416) the machine was detected, but starting the homing cycle the connection gets lost.
2. try the same, 3. try: it works till line 1037.
Afterwards same behavior as before :nauseated_face:
Has somebody an idea what I can check ? Machine is only some month old and not used very often. PC is only used for the CNC.

LedHolzCC.nc (102.8 KB)



0 Likes

(William Adams) #2

You can test if the problem is with the file by putting Grbl into “Check” mode by sending $C to the machine using the MDI, then sending the file — Grbl will process the file sent by CM, but the machine won’t move.

If the file tests out okay thusly then it’s probably EMI: https://wiki.shapeoko.com/index.php/Electronics#Recommendations

0 Likes

(Peter H) #3

I did a test without a cutter and it works. So no problem of Grbl.
After adding the cutter, problem was the same.
I unplugged the power supply of the notebook and it works with cutter. I ordered some chokes and will try if this will help.

1 Like

(Arjan van de Ven) #4

your USB cable might also be suspicious…

I use https://smile.amazon.com/gp/product/B01L81WQ2O/ and have not had problems

0 Likes

(Dan Nelson) #5

2 things I can think of off the top of my head:

  1. When you do the air cut, no cutter, are you using whatever dust collection (vacuum, shop vac, etc.) as you use when actually cutting? If not maybe your vacuum is building up static and causing a disconnect due to EMI. Is the router running during the air cut? If not possible same issue. There are several forum posts about solving EMI issues, I think @WillAdams likely has a wiki page with possible solutions. Edit: Yes he does, I should read the full post before responding, my mistake.

  2. You mentioned using a dedicated laptop. Is it plugged in and not running on battery? Are every single power saving and sleep mode options turned off?

Dan

0 Likes