Major problem with shifting Z axis during job

I was in the process of making a new wasteboard. I started the job which is 30"x30" board and total of 81 holes. I zeroed out the XXL using the probe (X,Y,Z) and loaded the job. It starts out fine but after getting into the job a way, it starts cutting the first plunges into air (litterally). The first time this happened, I clicked “pause” then clicked stop. It plunged all the way down, then back up, then moved to far right corner. When I jogged back up to anywhere on the board and moved the spindle (with 201 bit) down to the wasteboard, it was right at 0. So that means the z axis zero was still correct, but yet while it was running the job, something got bad off.

I re-probed and then reran the job. This time it did the same thing but it was further into the job before it happened. Any ideas what could be going on here? I can make and put up an unlisted YT video to show what is happening if need be. Thanks for any help.


I created this in Vcarve pro. Let me know if I need to upload the Gcode or the Vcarve file. I don’t think there is anything wrong with either of those.

more likely a case of Z axis slipping

Will will have a nice checklist, but check to make sure the Z belt is tight and the set screws in motor axis are tight


Thanks Arjan. I will look for a list from Will. I just got home and I am about to head out there now and start looking things over. I tried to run the job this morning and then had to leave so just now getting a chance to go see if I can find any problems.

Check the set screw on the Z axis pulley.


If you want to zip that VCarve file and post it, I can take a look at it. You can visualize the GCode with CAMotics to see if the code behaves properly.


Hi Luc, I am attaching the Vcarve file (zipped). I believe this has to do with the Z motor. I’m not sure what else it can be. I recorded video while the job was running. And I show where the problem begins to occur.

Here is the video:
This is an unlisted youtube video.
The first 2 minutes show what I checked. The problem begins to occur at 5:56

I removed the spindle, and Z Axis plate.
I removed the belt and checked it for any damage (there is none).
The tensioner was fine and the belt tension was fine before and after checked everything.
The Z motor shaft and sprocket are fine.
The Z belt bottom pulley is fine
The concentric nuts are set properly.

There is absolutely nothing wrong with the Z axis assembly. So I have no idea what the problem can be.

30x30 9x9 Waist Board Setup - (278.1 KB)

I looked at your project and it looks fine except for the lines at the end where you set the start height at 0.0 but you have just resurfaced the top with the Whiteside surfacing endmill so your start depth is lower however this is not an issue if you do no have the BitSetter but it is something to keep in mind. I cannot try this project on my Shapeoko as I have an XL not an XXL.

I would say that there is a problem with setting your zero or you have a mechanical issue.

1 Like

Thanks for looking at that Luc! I designed the lines so that they would intersect the holes but it would be run as it’s own job on the “top side” after it was surfaced. So the holes would be done as one run, flip the board, surface it, then 3rd job would be to do the profile grid lines. I am hoping that Will can look at the video and provide some insight on what might be going on. Thanks again for helping me!

Hey Tim,
Had the same thing happen to me numerous times, From what I gather (only been at this for a little over a month)is that it is skipped a step, once this does it – your done, you have to re initialize and re zero and run it again, I was lowering my bit a little as well, as well as removing one of the springs also seemed to help a little but more so lowering the bit down more—at least for me. It seemed to do it more for me on the smaller bit -.063, not so much on the .25. Also make sure your bit is not slipping in the collet.

Hey Don, i have the #201 endmill all the way up in the collet so it is not a slipping issue (and I have it good and tight). After this happens I initialize X,Y,Z using the probe and the problem continues to happen when I rerun it. So did yours problem finally go away? I have not tried removing a spring but I will try that.

One thing you could check is if your router is tightly held in the mount. If the pressure make the router move up say 1/4in then it goes down by the router weight when Z goes up. This could occur without you noticing.

1 Like

Luc, the spindle is very tight. I removed the Z axis plate and belt to double check everything and then put it back together and the problem still happened. The video I linked above was after I completely checked the Z axis assembly. I have emailed support and hoping they can help me resolve it.

Tim I had not watched the video but here is something to try, I’ve had a similar problem twice before and it took a while to resolve. At the beginning you mention tightening the grub screws of the drive gear. These screws can appear tight but they are not. I have removed all of them and replaced them with M3 cap screws. The head of the grub screws is much too small and the allen wrench will easily slip if they are stuck in LocTite. You can put a lot more torque on a cap screw that has a much larger head. As a result, the shaft will not slip.

I will certainly do that. Even though the screws seem very tight, that is a very logical explanation as to what could cause this.

One thing I forgot, I completely loosened the screws on the z motor drive gear and I could not get the drive gear to even budge. I was going to slide it off and observe the shaft but could not. I did not want to pry on it and force it off and mess something up. The flat side of the shaft was perfectly aligned with one of the two allen head lock screws so I assumed all was good with it. I will still replace just to be sure.

You have to use a puller to remove the gear. While it will not come out, under normal usage force, it can spin. It does not take much to mess-up you project. Even if this is not the root cause, you will avoid problems in the future.

Luc, after more testing I am convinced you are 100% correct that the sprocket is slipping on the z motor shaft. I swapped out the tiny set screws for some other 3mm screws with a larger head on them. After it kept slipping I tried to tighten them even more… until I broke the head off one. So I went ahead and ran the test again and still the same problem. So now I will just deal with Tech support to get that motor replaced because it will be near impossible for me to back out the 3mm broke off stud and it appears no matter how tight, it will continue to slip. There is no reason for this to have been slipping so it is very frustrating to say the least :frowning:

1 Like