MeshCam not completing figure and Switch Limit hit when about to start machining


First off, thanks to everybody that has helped me thus far.

I am encountering two new problems. The firs one is that MeshCAM is only giving me the code for a Face. Its a cube. I set the waterline halfway through, but it still only does the face, not the outsiide of the cube. On the end is a screenshot of this. Also a Screenshot taking away the rouging lines so that the piece is visible.

The second is a topic I that has been discussed, but I tried what the threads said and nothing.

I connect the Nomad, home to Zero. Then I click the Begin Project. However here is where its odd. It moves as its about to start milling, the tool is rotating, and just as it reaches the zero point, the motors stop going down. It goes up again, moves to the top of where it measures the tool again and stops saying its hit a switch limit.

I tried shutting off, restarting the computer, moving the tables and centering manually, starting the machine again, and do everything again. And the same thing happens. It looks like its about to start cutting and again the tool goes up, places itself on top of the measuring button (not touching it, but at the top of z axis) and stops with the same message that its hitting a Switch limit.

Any thoughts on these things?

Thanks a million once more.

@aderienzo, it would help to attach a screenshot of your Toolpath Parameters screen. It looks as if you might be specifying Machine Geometry Only with a margin of zero. To machine the outside of your part, you need to specify a margin of at least the radius of your cutter, or else Machine Whole Stock.

How tall is your workpiece? If it is tall, and you are using a long tool, and maybe specifying a large Retract Height, MeshCAM might not be able to move the tool up far enough to reach the retract height without hitting the Z limit switch.