Meshcam Taking AGES to generate tool path

(Aroldo de Rienzo) #1

Hi,

I made a turnercube, like a few before, and I put it into MeshCam. Since the side That was above was the incorrect one, I changed the side that needed milling.

Here is where the problem is. When I do the Toolpath, it simply makes a cube, not a cube with the cylinders borred in.

I dont know if anybody can give me a hand with this.

Below is what Im trying to machine, and the result of the toolpath.

yours,

0 Likes

(Mark Bellon) #2

Welcome to the forum! We’re here to help!

Yes, the computation can take a while. If your machine isn’t a 4GB plus RAM machine with two or more screaming cores you will have to wait… or play with the amount of data emitted. The more data MeshCAM has to work on, the better job it can do with the machining.

In general, your CAD should spit out as fine an STL mesh as it can and the roughing tolerance should be 0.0001" (or 0.0025 mm).

Could you please post a screen shot of the parameters you’re using for the machining? That would help us understand what’s going on. Could you also please make sure we can see the scale of the cube (1 inch, 25 mm)?

One thing that may help is to enable the use of G02/G03 (G-code for circles). This is currently commented out of the MeshCAM post processor for the Nomad. This is an optimization… we can go there once we figure out what’s going on.

mark

0 Likes

#3

@aderienzo, your screenshot is looking at the top of your workpiece but it looks like the toolpaths are coming up from the bottom. Did you rotate the geometry in MeshCAM? I don’t see the red-green-blue axis triad so I’m imagining it is on a far corner of the stock.

What should be individual green lines of the toolpath are so close together that it appears as a solid green surface. I would guess that your stepdowns are very small. I’ll echo Mark’s request for a screenshot of your Toolpath Parameters screen. Also make sure that MeshCAM imported your STL at the correct size. You can confirm that in the Geometry | Geometry Properties menu. But that is usually a problem of people working in inches that accidentally import a millimeters STL so their geometry is 25.4 times as large as they think it is!

Randy

1 Like

(Mark Bellon) #4

@Randy - The XYZ is pointing to the wrong face (as you expected). MeshCAM is machining a flat cube face. He sent me an STL and I can get it to do the expected.

I tweaked the tolerance, step down and such and the result is reasonable.

mark

0 Likes

(Mark Bellon) #5

@aderienzo,

The STL file has the nested pockets on the side of the cube, not the top. I used the MeshCAM rotate button (second from the left) to select the correct face, established the XYZ point in the middle of the face (with the nested pockets), adjusted the milling parameters and off things went.

The STL file is too course for the curve fitting to work. With lots more data - 1 degree triangles always work for me - the generated G code would be much smaller.

mark

0 Likes

(Aroldo de Rienzo) #6

Thanks a million. Ill work on it and post a picture when its finished.

0 Likes

(Aroldo de Rienzo) #7

Ok,

So on Solid Works, the degree triangles are in the Options part when you are SAVING the document after I set the file type to .stl. Took me a while to figure this out, I was trying it on the Program Options… Just posting this incase someone experiences the same problem. And it majorly decreases the time it takes to generate the toolpath.

Im still having trouble putting the XYZ point to make it point upwards. I set it to anywhere, tried rotating the part, etc but still points inwards (towards the part) instead as how @mbellon has it on the picture thats posted… any thoughts? GRZ forum is extensive, ill keep looking, but I havent found the solution…

Thanks for all the help thus far

0 Likes

#8

@aderienzo, check out the threads http://grzforum.com/viewtopic.php?f=3&t=15522&p=24669#p24669 and http://grzforum.com/viewtopic.php?f=3&t=49&p=289#p289 for two kinds of advice on working with files from SolidWorks.

Randy

1 Like

(Aroldo de Rienzo) #9

Ok Guys,

I did it.

It turns out that its all about playing with the rotating of the geometry. If the XYZ axis is looking INTO the part, its just a mater of setting that to the TOP and the XYZ axis will now face AWAY from the part.

I know it sound silly, but im posting this because it took me a few hours where I remade the model con CAD and still had issues. So it might save someone some time if they see this.

Ill post a picwhen I machine the part.

yours,

0 Likes

(Mark Bellon) #10

I did it.

Congratulations!

Sorry if my explanation wasn’t in sufficient detail to get there faster.

Every CAD package has a BIAS is how it emits an STL file. Often, the emitted geometry does not match what you see on your CAD screen. That is what happened here. The STL file you sent me had the nested pockets on one of the sides.

This is why MeshCAM has the rotate button, to select the face to be machined.

My method is to move the XYZ zero to the center of a face - I find it easier to see - and then choose the face. Once I have the right face I can easily move the XYZ zero. YMMV.

mark

0 Likes