More downtime than machining

Okay I need to know if I’m the only one having repeated issues with the Shapeoko Pro, because at this point it feels as if I was sent a damn brick and I’ve never had so many problems with any machinery in my life.
I’ve contacted and kept up with support through every issue, though the response time has been less than appealing (not even close to 3-4 hours as the auto-reply states, more like 24ish hours and sometimes several days.). However, once we’ve established that the issue is due to a manufacturer issue they’ve been hasty to send out replacement parts, and I’ve received quite a few…

I had been wanting a CNC from Carbide for years and I finally bit the bullet and chucked my card at the Shapeoko Pro, because you know… go big or go home?

Unfortunately I’ve had issues since day one:
After assembly I was unable to initialize the machine because the cable going through the gantry to the left motor was defective, one of the wires was missing continuity, so broken connection somewhere in the gantry?
I contacted support and after some back and forth I was sent out a replacement cable.

After hooking the replacement cable up I was able to initialize the machine…yeah no, just kidding.
This time it was my X homing switch that was faulty so the CNC just tried to Hulk itself through the Y-rail.
Contacted support again… and once more after some back and forth we concluded that it was due to poor connection between the switch and extension cable, the molex was poorly crimped.
I was sent out another set of cables…

Awesome, sweet, new cables lets go!.. Nope not this time either…
This time my left stepper motor was whirring and pointed towards a bad connection between itself and the extension cable, again due to poor crimped molex.
And not only that, but the Z motor was having issues as well and was feeling way hotter than any of the other stepper motors.
I pointed a temp gun at the molex that connects the Z motor with its extension and I got a reading of 92°F and it was climbing still… I turned off the machine when I had a reading of 125°F.
Contacted support again… because what else?
Back and forth, testing, moving motors around, tapping connections.
A replacement left Y motor was shipped out.

Alright maybe now… we get to actually run the CNC properly?
…No, of course not.
This time around it was my Z-plus that was skipping, to the point of not being able to establish proper Z0 at all.
Back to support! After some email exhange I had a video session with support who helped locate the issue, the skipping was due to screws not being tightened down by the manufacturer so I had to raise Z all the way up and line up hole on the back plate with the screws behind it.
Once said screws was tightened the skipping was gone.

Obviously after dealing with so many issues and waiting for support since day one, my return window was far gone.
So let’s just carry on to the next issue, the Carbide Compact Router.
I almost had a successful run, until the machine started going deeper… and deeper… until I paused the milling process (luckily I was standing right there, since I have no confidence in this machine). Turns out the bit had started to slip, okay cool, maybe I weak sauce tightened it?
I removed the nut and cleaned the precision collar and spindle with a toothbrush to get all the MDF dust out. Slipped the bit back in and tightened it back up… and that’s when the actual metal part of the spindle that keeps the lock in place etc… snapped. Mind you I’m no damn Iron Man and you’d figure the stamped wrenches would give in before the router?
The break looked rather clean, like a straight hairline fracture, so I’m assuming manufacturer defect?
My only form of ‘investigation’ was a round of select ‘adult words’ while taking some pictures and writing up another email to support.
I didn’t have any patience to wait however, or time since I had a piece to get done for a client. So I went and picked up a Makita router from HD.
After installing the new router everything seemed to be working as intended… finally (I believe this was 2 weeks ago).
Support was hasty to send out a replacement router without too much back and forth so I’m assuming they established that it was indeed a manufacturer defect.

Which brings us to… today and my current issue, the Z-plus is skipping again.
Of course the first thing I checked was the screws we tightened up earlier in this amazing adventure of problems.
This did nothing, they hadn’t budged since the first time. I checked every other screw I could possibly find and made sure everything was snug… still didn’t fix it.
So I contacted support again and explained the issue (also included a video, which I’ve been doing with many of the issues I’ve had), this was a week ago and the problem is still unresolved to this day.

Now… I don’t think I’ve ever regretted a purchase as much as I am doing this one.
I’ve ‘owned’ this machine since late September and for most of the time it’s just been collecting dust and costing me a ridiculous amount of money, time and sanity.
How is this even okay? What do I do with this? What’s going to break next?
The next time someone tells me to “Buy American, Chinese crap just break” I may just slap them across the face…

1 Like

This isn’t typical.

If you haven’t already, please send this in to and we’ll do our best to work this out with you.

1 Like

Everything is already in the hands of support, hopefully Fleming can sort my cursed machine out for good, or take it back…


I feel compelled to respond, you are not alone with these same problems.
So far in just over 2 months of having this machine I have completed only 2 projects which both barely got done after much work on the machine.

If I may offer a suggestion, aside the many bad crimps and wires coming loose, ditch carbide motion.
All my problems arise from the fact I cannot home the machine. So I have no idea where I am at in X, Y axis. IMHO it’s easier to control the machine using CNCjs or something like it. It looks like it’s moving too fast using carbide motion, which is partially responsible for my machine skipping.

And yes I have sent e-mail to support, still awaiting a reply after 2 days

Just used CNCjs for the first time, today is the first day the machine has just worked without something going wrong.

1 Like

Both glad and sad that I’m not alone with repeated issues.
I don’t think moving to another control software would help in my case however, as I have a feeling mine’s a mechanical issue. There’s a very distinct sound and I can literally feel the machine moving irregularly if I hold my hand on it when it descends, but it moves fine on the return upwards and both X and Y seem fine too.
As for support… well I’m rolling up on day 5 with no response now, day 9 since first reported :weary:

There is risk of this sort of thing on both parties here:

  1. The customer buys it as a kit, there is the possibility of error in assembly and usage of parts which have not been tested
  2. The supplier sends a kit of parts, many of which may be untested and will put a support burden on them.

I went around this loop with 3D printers (built my own RepRap Mendel in 2010 from a kit of parts) and after 5 years of spending more time ironing out issues and improving quality than I was printing projects I eventually splashed out on something which arrived in a box fully built and tested, mostly due to accuracy limits of the Mendel frame. From a productivity and quality view, I’ve never looked back but the Mendel gave me a lot of insight into what to look for in a pre-built machine.
When it came to a CNC, I knew I wanted pre-built, hence bought a Nomad which has been accurate and reliable (apart from some play in the spindle bearings which was sorted), although it is a bit underpowered for some of my projects (I need MRR patience!) Whilst I believe Will that your experience is “not typical” it is inevitable that a kit is going to take more effort to run smoothly.
Carbide3D Support know their stuff and will get you there. A kit is teamwork, so have faith and patience.


Your most recent pairs of e-mails in to support came in late Friday and late yesterday evening and were assigned to a person who doesn’t work weekends — you should see a response as we work through the queue.

We do our best on the support queue, and try to answer all messages in the order that they come in, but if you have a ticket which is assigned to an individual, and need an urgent response, it’s best to send in a new message to


Yup, I’ve been peppering Fleming(?) with additional updates and information that hopefully can be of use for him whenever he gets to my case. Naturally I wasn’t aware he doesn’t work during weekends or delegates to someone who does, but I’ll make sure to send new tickets straight to the main hub in the future.

1 Like

While one shouldn’t blame you as the the Makita manual does say it is okay to use the lock to tighten and untighten, it might be more practical to just use two wrenches. The lock is helpful when putting on and taking off the nut by finger, but I personally don’t use it to hold torque. Using two wrenches puts much less stress on the connection to the rails (which has the danger of shifting your position slightly).


Both wrenches were used, as mentioned ‘stamped wrenches’ :slight_smile: button lock is just to get finger tight and keep the bit in place indeed.

1 Like

Please note that our recommendation is to use the button only to hand-tighten so things will stay in place, and to then fully-tighten using a pair of good quality wrenches (low profile 13mm, 22mm stubby)

1 Like

You mean your shaft broke? Count your blessings then that it didn’t happen at 25k RPM.

1 Like

Totally understand this part of course, it’s just the frustration of constant failures that gets me really. I do plenty of 3D printing myself so I certainly know ‘the struggle’ per se, and part of the charm is the actual tinkering. Though I’m still somewhat hesitant to tinker with the Shapeoko Pro as of yet (…to a degree) because of the price point itself really :slight_smile:
I just want this to work so damn bad lol

I got my machine the late spring 2020 timeframe. I don’t recall at that time many people were having wiring issues. That leads me to think that either or both of the following has occurred:

  1. if the problem rate is the same as before, it could be that the volume of machines Carbide3D is shipping out has increased by a lot. I doubt this accounts for the issue though as the price hasn’t really come down or the technology improve to really change the market suddenly.
  2. something has changed in harness fabrication / sourcing / quality control process that results in a higher problem rate getting out to the customers.

I know this is of little comfort to you, the customer facing the problems. Hopefully the volume of issues prompts Carbide3D to improve quality on their side. But know your Shapeoko Pro has good bones!

Got on a call with Fleming and went through the Z issues, ended up with him sending out a new Z-plus that arrived the next day.
Swapped it out this morning and so far (…hopefully I won’t jinx myself) everything seems to work as intended when jogging. Remains to be seen if it runs fine during machining too… fingers crossed!


I had a similar issue with my z limit and z axis motor, I just cut the connectors off and soldered them together works much better this way and was only down like 30 minutes. Also had my collet come loose and the bit dove into my waste board and into a t-track of course :rage:, I’m extra attentive to making sure it’s tight now.

Please note that the official suggestion here is some sort of mechanical connection, rather than soldered which our experience has shown as a tendency to give way over time due to machine vibration.

Please contact us at if you would like a new set of wiring extensions and if need be, a motor w/ connector

Cleaning the shaft and inside the collet with a little Isopropyl alcohol will help too.

A little spray bottle, just a couple oz, with the alcohol in it and spray on a rag or paper towel, those blue shop towels are great too, then wipe off the shaft part going into the collet. Spray a little on a q-tip and clean the inside of the collet.

That will get rid of any oils that may be on there and help give you a much better grip on the tool.




You’re definitely not the only one. I got my Shapeoko 4 XL in the summer and it was missing several parts. Support was good and eventually sent me the right parts. Unfortunately, it only works about half the time. I’ve had intermittent grinding noises with the Z axis. Sometimes it’ll be too high to cut into the material, other times it’ll go too low relative to the rest of the cuts. One time the Z plunged completely through the board and into the hybrid table. There’s a tiny dent because I wasn’t able to stop it on time. Another time it wouldn’t home the Z axis (it was all the way up and the couldn’t detect it). I did some back and forth with support, but I work full time and don’t have any vacation days left to do a video call during the day. Especially when the problems are intermittent. It could take days to even see it happen. I ran a job that took 30 hours with no issues. Followed by a 20 minute job that failed 3/4 the way through. I’ll try support again when I get vacation time next year.

In the absence of a video, please send a description of the problem and photos of your Z-axis wiring, esp. the connectors, esp. the logo on the connectors in to and we’ll get this sorted out.