Move jaw of low profile vise

(Phil Bresnahan) #1

Dear community,

I’m a complete noob here and am on a mission to ask what seems like the dumbest possible question… Please forgive my complete ignorance. I’ve followed the first few tutorials/how-tos for the Nomad 883 with great success and am now facing a very silly problem: I can’t figure out how to move the jaws of my low profile vise. I’ve taken out the vertical set screws but the silver-colored jaw on the far left really won’t budge. It seems like it’s supposed to, right? I want to open it up more for a larger piece. Obviously I can change the positioning of the workholding piece in between the outer two jaws by changing how far in/out the horizontal screw on the left is threaded but I cannot for the life of me (even after a long time of googling and (workholding) forum-reading) figure out how to move the outer jaws. Thanks in advance for your help!

0 Likes

(William Adams) #2

There should be two more blue socket head cap screws which fit in the left-most silver part.

The way it works is:

  • place stock against right-most (unmoving) part
  • slide movable (middle) part against stock
  • slide left-most part up against it — use the two blue socket head cap screws to secure it in place
  • use the stainless steel button head cap screw at the left to push the middle sliding part against the stock and secure it
0 Likes

(Phil Bresnahan) #3

Thanks for responding. Yep, I understand how it’s supposed to work but the left-most part is not sliding. I took the two blue SHCSs out completely in order to try to move it but it won’t budge.

0 Likes

(William Adams) #4

Try putting a solid block in, then getting it to move using the bolt?

EDIT: if that doesn’t work, contact us at support@carbide3d.com and we’ll work out what to do.

1 Like

(Phil Bresnahan) #5

Clever—that worked. I was able to push out the left-most piece slowly and then clean it on all sides and the bottom bracket of the vise. After everything was pretty clean, it started sliding much more easily. I couldn’t even move it with a mallet earlier! I was surprised it was so dirty as I’ve only used it on the one wrench part from the first tutorial but this seems to have solved the issue. Thanks!

1 Like