New user - BitZero/Probe not behaving

New user with a Shapeoko 3 XXL and using Carbide Motion on Linux on a Raspberry Pi with a touchscreen interface.

According to the BitZero user guide, I’m supposed to position the end mill within 1/2" (on the Z axis) over the dot in the corner of the BitZero block. Here’s the version or type of BitZero I have:

I tried to use this and put the tip of the end mill 3/8" over the metal block and used the Probe function to set the corner (i.e. X, Y, and Z). When I touched the button in CM to use the probe to zero it, the carriage moved a small amount along the X axis but did NOT move along the Z axis at all. It did not go down to find the height of the metal block.

Is this a problem with the Linux version of CM? Am I doing something wrong? Is there a setting I can change?

How can I get BitZero working on my Shapeoko? (So hoping I’m not asked to use a Mac or Windows system to run the Shapeoko - I have a Linux workstation in my shop and I’d have to buy a new computer to use Mac or Windows there. (And running a USB cable from a desktop to the CNC would be a big pain.)

Hi @Tango,

This is a “bitzero v1” model. If you are using a recent version of CM, you need to double check in the settings that bitzero v1 is what is selected. Then:

  • what probing option did you select in the pull-down menu ?
  • do your probe operate correctly i.e. green light goes to red when touching the clip against the probe body ?
  • can you double-check in CM Settings page, on the GRBL Active Input Pins section, that “PROBE” input is not already active even before you start probing ?
1 Like

In addition to Julien’s notes - the version 1 BitZero will trigger if it sits on (or even near) metal and the light will go red… so that’s something else to watch out for.

2 Likes

Yes, it was a V1 BitZero. I changed the setting and it worked fine. Thank you!

1 Like