New XXL Build - won't complete Homing process

Using the flashlight on my cell I can ~just about~ read the connection requirements on the silkscreen, and directly above the connections to ensure I’m correctly wired (X to far left, then Y, then Z to the right. The remaining 2x connections to the far right are unused, correct?.

It’ll start running the Z axis test without issue, but then when it tries to run the Y axis, the gantry moves all the way to the rear of the machine, hits the limit switch and stops dead. it won’t jog backin (as the Z axis did), and sits there indefinitely.

I followed the instructions to ensure that my settings values were correct (Homing = ‘true’, machine ranges to XXL requirements of 850 & 850 respectively)

Yeah, some of the connectors are un-used.

Here’s a nice photo showing labeled connections:

That’s exactly how mine looks (though I used painter’s tape to label my connectors… Your way is smarter, and shall be ‘borrowed’! :wink:

I’ve fired an e-mail to the support team - hopefully they can help me out in short order. Assuming the issue isn’t an “ID10t” error at this end, I’ll share the results on this thread. Hopefully it might help others in the future?

Appreciate your help though.

I think we may have a mis-understanding of what “homing” is in this context — it’s the machine finding the machine origin, which is defined as the top, back, right corner of the machine.

Once that’s done you have to manually set up some position on the machine to be the origin.

Please review this tutorial: http://carbide3d.com/docs/tutorials/tool-change/

No - I’m stuck in an endless cycle at step#8 of the limit switch config:

http://docs.carbide3d.com/article/67-shapeoko-3-limit-switch-installation

My z axis works fine, x isn’t operating at all, and y moves to the rear and stops. CMotion won’t clear out of “homing”, and each time I shutdown the software (and cutter) and restart, I’m prompted to initialize homing again…

My apologies — sometimes I mis-understand, and trying to cover all the bases.

My inclination here would be to go ahead and try the new Grbl 1.1 update:

There’s also instruction there on re-flashing to get Grbl 0.9 reinstalled: GRBL 1.1 and Carbide Motion 4

but I really wonder if there isn’t something wrong with the board, though I don’t understand that well enough to even guess what it might be.

No apology required, sir! I’m brand new to both this tool, and to these terminologies (I was alsoworking on this “challenge” 'til VERY late last night, then up at the crack of dawn again too, retracing my steps to find any faults that I could’ve made!

I might hold-off on any re-flash 'til I’ve spoken to Tech support @ Carbide 3D - I don’t want to be held responsible for trying anything ‘unauthorized’ (unless you’re a C3D representItive, Will?)

Not a representative — entry-level, off-site, remote tech support, part-timer who has freelanced in the past, and volunteers somewhat on the wiki.

As I noted, it has me stumped. Hopefully one of the folks who actually understands this stuff will chime in, either here, or on the support e-mail.

Lol! Gotcha.

I made a video to demonstrate my issue - though interestingly, the y-axis came to a halt BEFORE the limit switch was depressed on this run… let me see if I can post the vid

(And please excuse the accent of this ex-pat Brit in Canada!)

are all the settings set for an xxl? mabie post your settings for everyone to view and someone might see somthing.Just an idea if you are waiting to hear back from c3d.

Hi Mark,

I believe so - per the limit switch instructions, I changed the table x and table y settings (lines 1006 & 1007) to “850” each to match the requirements for the XXL

Darren

:

ok try this,go to settings,open the log,leave it open and go to mdi and type $$ and upload the log with the info,ill add a pic for example in a min

Will do - just as soon as my daughter finishes her play-off hockey game! :wink:

1 Like

Back. Game was cancelled - only one of the two required refs turned-up!

So on typing $$ into MDI, I get a page and a half of log files, split across the two following images… I hope that they are legible?

In the meantime, I received an email from Carbide 3D - for “weird issues” like this, it sounds like a Skype/FaceTime call is their preferred option…

change your $130 and $131 to match your table atm its set at 400.00 and 425.00 thats the stock shapeoko 3 size you have the xxl correct? try changing too 850.00 like you see in my pic,ive seen others set it to around 840.00 ish but i havnt had any issues with mine so in mdi try $130=850.00 and send and $131=850.00 and send and try to run your homing again

One attachment per post, eh? Here’s the second pic:

think its for new users (which would need it most) Hint.hint to the forum gods…check above your last post,i stated some changes to be made that im thinking might fix you up :slight_smile:

Just came off of a FT call with Jorge (real good guy!) We ran through a series of diagnostics, and he determined that I have a “dodgy controller”.

He had me change MDI values, swap connectors left and right, and even direct-connect the x-axis direct to the controller (bypassing the extension cable in case that had a damaged wire in it). The long and short is that the x-axis controller is failing to initiate -at all- on the controller, so I can expect to see a new board sent over the border in the next few days.

Thanks for your help, gents - I’m quietly pleased that the idiot that put this machine together (me!) wasn’t the one responsible for buggering something up!!'ll report back to let you know whether this does indeed fix the issue, or whether Mark has hit on something, and I need to mess with the values within the log file, or maybe even consider the firmware upgrade options

1 Like

yeah,the whole carbide team is awesome,you may need to change the new one to the values discussed earlier $850.00
if so just refer back to this post,let us know how it goes and welcome to the forums Darren :slight_smile: