Newb Q's about the SO3-XXL - Jog/Home/Carbide Motion

Hello Shapeoko Forum dwellers -

I was hoping my second post would be contributory in nature… I will eventually post up some easy liberties/tweaks I made when assembling my XXL, but for now I’m trying to get past my newbish’ness when it comes to basic machine operation.

As background, I’m all-up assembled and have run the proverbial “Hello World” Sharpie drawing… all was functional in scale and operation.

As my next exercise however, I thought I’d try general jogging and homing ops in CM. From what I’ve read, HOME on a Shapeoko3 is at the upper right corner (X,Y) when standing at the front, and Z at the “full-up” position. These same locations are where all my limit switches will actuate as well.

When I jog my machine however, the movement seems “backwards”. In my mind (+) movements should move AWAY from Home (0,0) and (-) movements should move TOWARD Home. Instead, my jogging moves as follows (oriented from the front of the machine):

X+ = from Left to Right
Y+ = from Front to Rear
Z+ = Upward

Furthermore, when I enable HOMING (placing everything effectively at Center) and then start it, the X-Axis starts moving from Right to Left, opposite from where Home is defined. It eventually stopped, and then CM throws a “GRBL Error : Setting Disabled” dialog.

I can post up my $$ settings if required (I’ve actually got an email into support), but thought I’d reach out here as well for communal support.

Thanks in advance for any assistance.

Those are the correct directions.

Please review: and use

Thanks WillAdams -

Glossary reference is golden and matches my movement and jogging (I’m the inverted entity). I’m still confuged by the Homing operation and why the machine first moves in the -X direction and stops. Shouldn’t the machine move +X +Y +Z to go home?

Your max Y and X settings may be set to the default (for the standard SO3) of 450mm. If that is the case the machine will not go all the way back to the home location, depending on where you were when you pressed $H to home. So I would make sure your settings are correct. So if you post them here we can take a look.

Do you have homing switches installed and have turned on homing?

CM Settings
1005 Shapeoko Has Homing = True
1006 Shapeoko Table X = 850
1007 Shapeoko Table Y = 850

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)

Noticing “Max Travels” are not XXL reflective.
Limit Sw’s are in and actuate at full X+ Y+ Z+
Homing operation in CM starts X moving in -X direction

In your $$ Settings, make these match your Carbide Motion settings -

$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)

So set $130=850 and $131=850

And set $22=1 to turn on homing

Someone who uses Carbide Motion should verify. I use Universal G Code Sender, so I only use the $$ Settings, not the Carbide Motion settings, but I would assume that the GRBL settings need to be corrected before it will work properly.

I get the notion of setting $130/$131 respectively, however the machine is likely going to still travel in the -X direction, just farther with these overrides. The $22 = 0 setting snapshot was in between me cycling homing on/off via the CM Settings control.

$23 (homing dir invert mask) will likely flip the direction, but what’s puzzling is the why direction of the homing operation is the exact opposite of what’s expected… and why the GRBL Error : “Settings Disabled” dialog pops.

I may play around with the masks to see what happens.

Forgot to ask of anyone who has homing operational in Carbide Motion…
What’s the sequence of homing operations?

  • X first, then Y, the Z
  • Z first, etc.

Thread update:

I received an email from Ed who ref’d this homing article (this answered the homing sequence Q)

I reset all the applicable $ settings ($22, $130, $131) as suggested, and also flipped on “Shapeoko has Homing” in the CM Settings page. Nav’d over to the “Jog” control in CM, clicked HOME… nothing.

I turned off the CM “Homing” setting, and simply issued a $H from the MDI control…
Homing Success, with the default 5mm back off!

I immediately tried manually jogging in CM clicking the -X button, but instead got a LARGE -Z movement instead. Thereafter, jogging was correctly restored.

Hi Jim
i am having the exact same problem with my XL machine

First of all i Have not got a clue about cnc,
i draw in 3d and have no trouble getting stuff out of my 3d printer.

would it be possible to send me the settings you have on your machine,
i can adjust the working size from xxl to xl in the CM settings not a problem
But how do you enter the $$ values required
Thanks in advance

Open CM and invoke Settings Controls, Click the LOG button…
Resize/position your workspace and log window so you can view both.
Click the MDI Controls.
Command syntax is $XX = YYY

Enter the required adjustments, and validate they are set using command $$ to list current settings.

Thanks Jim
any chance of a copy of your settings or can i use the ones at the start of this thread

All settings above are the same excepting $130/$131. 850mm is the XL/XXL max travel.

Will try tonight thanks

Did this solve the pop up screen of not connected

I received a GRBL Error pop-up, never had a connection issue. The GRBL Error only occurred when trying to use the CM Home operation, and homing worked when using the $H command,