No lights, no power. Help!

So I’ve been using my XL for a few months now and have had zero problems so far until today. I went into the garage to load a new project and the machine will not turn on! No blue light or anything.Yesterday I used the switch on the power supply to cut the power, moved the router out of the way, removed my project and put my computer into sleep mode as usual. Today, I went to turn it on and there’s no light and there’s no slight jerking of the router stepper when I flip the power switch. I took the computer cover off and hit the reset button–nothing. Unplugged everything, plugged it back in–still no light, no power apparently. I REALLY hope I didn’t fry the board somehow :disappointed: Please help!!

Maybe it’s the circuit breaker?

No, I have a 3 way extension cord that the computer and router are plugged into as well and all are powered

EDIT: I switched the plug from the extension cord to a single outlet and it powered up momentarily, but as it was a long stretch to the outlet, the power source box thing dropped a couple inches and it powered off again. I got it to light up briefly again for a few seconds and then it crapped out again. I’m stumped!

I have to leave for a few hours, but I’ll be back here as soon as I can, as I’m in freak out mode lol

Sounds like a power supply short. Its not really a unique power supply however, you should be able to find a replacement is a good electronics store.


crap, hopefully I can get one at microcenter or fry’s instead of ordering online. There are few things worse than waiting for a small component to come in the mail to get you up and running again!
thank you for the help, i hope it works!

The power supply is noted as:

24V 5A Power Supply with DIN

at and (currently out of stock) is listed as a suitable replacement and the connector is ID’d at that first link.

Contact and we’ll see what we can do to help.

Either one should really have it no problem. a power supply that comes to mind that fits the bill is a security camera power supply normally they are 24 volt in the 5 to 8 amp range.

1 Like

Ok great, thank you guys!

UPDATE: I got a 24v 5a power supply with the right connector. When I plug in the power adapter the power box (not the CNC) lights up green. When you plug it in, the connector makes a very small pop sound and then the actual power supply itself starts quietly beeping at around 120 beats per minute i’d guess. Also the green light goes out. I hit the reset button on the CNC board and tried again, but the same thing keeps happening.

Please contact and we’ll do our best to help you sort this out.

were you able to figure out the issue? I’m having the same problem

If it’s on a brand-new machine, the usual problem here is mistaking the on/off switch for a ferrite bead — some of the power supplies have them (they’re tiny things) — switch to on, and you should get power. If not, please see:

Another possibility is a board w/ a bad part which requires one to press the reset switch each time one powers it up before connecting.

If that doesn’t help, let us know at what you’ve done and we’ll do our best to help.

i don’t see a switch on the power supply or USB cable. the green light on the power supply is on until its plugged into the control board. no lights on the control board and no connection to PC. I tried the reset button but still nothing happens. It would appear to be an issue with the control board. A new power supply is being shipped to me, which i wont receive until next Tues. Then if it turns out the board is actually bad i guess its another week. Going from very excited to very disappointed very quickly.

Okay, seems to be a bad power supply.

Please contact and we’ll do our best to get you a replacement as quickly as we can.

LewSlos: I got a new power supply from carbide, that fixed the situation. Luckily they’re only like 90 miles away from me so shipping was super fast. Best of luck getting it resolved!

Lewis, on my power supply the switch looks like a ferrite bead on the cable that runs from the box to the board plug. Isn’t there a switch on yours?

1 Like

Hi Russell, Thank you for the reply. I’m glad that fixed your problem. I hope mine is an easy fix too. The new power supply should be here next Tuesday.

Hi Jared, I looked it over and it doesn’t appear to be a switch. Ill try to look up the specs and see. Thanks again.

There must be a switch somewhere otherwise the machine would be turned on all the time the power supply was plugged in.

Hi Lewis (@LewSlos) ,

I am having the exact same problem you had. Did a new power supply solve the problem?