Nomad 883 Pro Default Settings ($$)

Can somebody send or refer me to the correct default settings for the Nomad 883 Pro? Thought I had seen them here, but can’t find them. Shapeoko 3, no problem. Nomad, not so much.

$H homes in the wrong direction, and ends up hard against the left side of the chassis. Setting the direction ($23=1) inverted just gets me hard/soft limit errors. I’ve messed something up here, can’t tell what. M03/M05 works, incremental movement works. Homing nope.

Incidentally, you can’t search the forums for “$$”…

$RST=* or $RST=$ just returns “bad number format”

I suspect that the Carbide Motion software will detect what sort of machine is connected, so the technique at will work for the Nomad.

Ok, here’s where I’m at.

I’ve got it back to defaults (I think) ctrl+1 in the info pane of carbide motion does so (I had ignored this earlier because it looked like a shapeko only thing…derp)

I’m still stuck. GRBL come up in an alarm state, which isn’t unexpected. If I start up carbide motion, it clear the error. Select “Jog”, click “begin homing” and things start to come apart:

___________$h ___________
___________N0G0X-120.000 ___________
ALARM: Hard/soft limit
[Reset to continue]
Grbl 0.9g
[’$H’|’$X’ to unlock]
<then more stuff as carbide motion reinit’s GRBL>

I’ve also tried just sending $H from universal gcode sender, and get the same result. I’ve power cycled everything. I’ve move the carriage (unpowered) to the middle of the range, moved the table off the limit switch. Power cycled again. I’ve moved and turned the spindle on and off via universal gcode sender…but I keep ending up in this soft/hard limit case. I’ve checked the limit switches, they are normally open as I expect, closed when tripped. (More after the $$ below)

$$ is:

___________$$ ___________
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=1 (dir port invert mask:00000001)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=200.000 (x, step/mm)
$101=200.000 (y, step/mm)
$102=200.000 (z, step/mm)
$110=2600.000 (x max rate, mm/min)
$111=2600.000 (y max rate, mm/min)
$112=1270.000 (z max rate, mm/min)
$120=270.000 (x accel, mm/sec^2)
$121=270.000 (y accel, mm/sec^2)
$122=270.000 (z accel, mm/sec^2)
$130=250.000 (x max travel, mm)
$131=250.000 (y max travel, mm)
$132=100.000 (z max travel, mm)
___________N0 G4P0.05 ___________
___________$# ___________
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]

Which shows soft limits off, hard limits on. If I turn hard limits off (which I think means ignore the switches) I get the same error (ALARM: Hard/soft limit) with $H. Very confused. I can still disable the alarm and move in all directions without causing an error, but $H does it every time.

Ideas anyone?

E-mail ?

Yup, think that where I’m at. Thanks all!

G58 looks out of limits based on :

$130=250.000 (x max travel, mm)
$131=250.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Turn off 21 hard limits:

Leave $22=1 and try to home it.

Hard limits are to enforce the 130 to 132 settings on the opposite side of the limit switches, at least that is my understanding of it. That being the case if it thinks it’s at G58 location, it’s way out of bounds. It should reset after a homing cycle completes once. Then you could reset the 21=1 if needed.

Will give it a try. Thanks!

Should I reset G58 and G59 to 0,0,0?

yes you could do that it may fix it. It won’t hurt anything to try

According to Jorge, The first two values on G58 are dummy values that aren’t used. The third should be negative (and is for me) I’ve tried setting $21=0, $H (hits limits alarm) $21=1. No dice.

definitely support time!

Been poking at this for a while. Had a couple messages back and forth with Jorge earlier, but was at the office so couldn’t set up a useful skype with him from there. It being after hours when I got home, figured I would pick at it and see what was going on…so I started over.

Bad Z-limit switch. When I checked it before, it was apparently stuck closed. After clicking it a few times with my finger, now it’s stuck open. Some better diagnostics would be nice, but I doubt there’s much room in the micro for it. Even a led on each axis limit switch input on the board would have made this easy to find. If the switch is closed and the light is on, broken switch. If the light is off and the carriage isn’t against that axis stop, broken switch.

The Sparkfun Stepoko board does have LED’s on the limit switch inputs.

Ok, all fixed. Gotta say, the Carbide guys are pretty awesome. They sent me a replacement switch overnight, which was way above and beyond what was really necessary, it’s all up and running again.