Nomad 883 Pro - Not homing - No movement at all

Hello Carbide 3D guys,

I finally received my Nomad Pro 883!! I am so stoked on using it. Sadly, I tried homing the the Nomad with Carbide Motion (the latest release) click the Connect button and it seems to connect. Go to the Jog menu and click Start Homing button and then nothing happens. Nomad doesn’t move a millimeter. I am using Windows 10, the latest release of Carbide Motion. I even tried reinstalling Carbide Motion without any success.

I have read another post that a user seemed to have the same issue and the recommendation was to re-install Carbide Motion, which I did already without success. The only thing I haven’t tried is to try another computer, but I need to have this work on the computer is currently connected to. I will try another computer just to rule out anything wrong with my PC.

I’m not sure what else to try. Any help would be appreciated.


@MrJJ I’m sure you have already done this, but have you made sure the E-Stop button is not activated?

There is no e-stop on the Nomad Pro. there is just a power button on the front.

My apologies, I have the original Nomad which has a red e-stop on the right side with a separate power switch on the left.

When powered up, are you able to move any of the axes freely? In other words are the steppers on and are they trying to hold position?

The only axis I tried moving was the x-axis and it moved freely with no hold on position.


I would definitely contact support. The guys at C3D have some of the best support out there. They will certainly help to get you going. It might be as simple as a cable that might have come loose during shipping. Let us know the outcome.

There is a real cluster of problem like this being reported by multiple people.

Please let C3D know.


Hi All,

I add a Skype call with Jorge last night, it looks like the board was fried during transport. Jorge is sending me a new board and hopefully this will fix the problem. I am really impressed with the service at C3D, never seen such good service.
Thanks Jorge and all at C3D!