Nomad 883 won't power on

Our school has had our Nomad for just over 3 years and had some success with it for the first 2 years, then we hadn’t used it at all last year due to pandemic issues. Anyway, I tried to get it going about a month ago for some new projects our students are working on this year and no response.

Pushing the power button does nothing. I have tried replacing the power supply based on another thread I found here but still no response with a new power supply. What’s the next step here?

Send an email to


Plug something into the outlet to make sure the plug is active. Attach your computer and see if you can connect. CM will show things if the machine thinks the door is open.

Thanks, sent an email and am in touch with support.

1 Like

Thank you for the response. Yes, checked the outlet. Computer won’t connect, probably because the Nomad doesn’t appear to be getting any power.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.