Nomad 883: Y-axis stepper not moving (UPDATE: X-Axis stuck now too)

Hi everyone,

Although I received my Nomad in February only just been able to start using it. Initially everything seemed fine but the homing get’s stuck on the Y-Axis (the Bed).

I’ve since removed the back cover and have switched the Y-axis connector from it’s Y1-axis plug to Y-Axis2 plug and that would allow Y movement in opposite direction!

I also connected the X-axis connector to the Y1-Axis plug but I can’t get beyond the homing screen.

Any thoughts & tips?

I put the y-Axis cable on the Z-Axis plug and immediately the Table move forward as if it was homing. So the Y-axis stepper seems fine and it must be the control board unfortunately.

Anything else I could try?

Sounds as if you’ve done a good job of trouble-shooting thus far. Contact support@carbide3d.com and they’ll get you squared away.

Hello Stefan,
I received your support ticket and it does sound like a board issue, Jorge will take care of it from here.

Thanks guys - had a very quick response from Carbon. Nice to see! :wink:

Jorge asked me to do the following:

Connect the Nomad in Carbide Motion, then press the L key to open a log. Go to MDI and type $#, then hit send. Copy the contents of the long and send them, I’ll flash a new board for you with that data and send it over ASAP.

So did that, and here’s the output:

Test Waiting... <Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.> ___________gc_not_motion___________ ___________$# ___________ [G54:0.000,0.000,0.000] [G55:0.000,0.000,0.000] [G56:0.000,0.000,0.000] [G57:0.000,0.000,0.000] [G58:553.000,883.000,-107.395] [G59:-123.320,-108.260,-126.970] [G28:0.000,0.000,0.000] [G30:-2.500,-5.000,-5.000] [G92:0.000,0.000,0.000] [TLO:0.000] [PRB:0.000,0.000,0.000:0] ok ___________gc_dwell___________ ___________N0 G4P0.05 ___________ ___________gc_get_offsets___________ ___________$# ___________ [G54:0.000,0.000,0.000] [G55:0.000,0.000,0.000] [G56:0.000,0.000,0.000] [G57:0.000,0.000,0.000] [G58:553.000,883.000,-107.395] [G59:-123.320,-108.260,-126.970] [G28:0.000,0.000,0.000] [G30:-2.500,-5.000,-5.000] [G92:0.000,0.000,0.000] [TLO:0.000] [PRB:0.000,0.000,0.000:0] ok ___________gc_parser_state___________ ___________$G ___________ [G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.] ok <Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.>

Thought it would be good for completeness / those with similar issues to include the whole conversation.
Big up to Carbid for their awesome support. Will keep updating this thread with my progress. :wink:

Got my replacement part within 2 business days. That’s me being in Europe!

Super stoked to have the part but then was delayed when I realized I needed cooling paste to install the replacement board correctly. That took an extra day to arrive (I didn’t have time to run to the local computer shop).

After install did a restart and lo and behold… nothing happened. Just funky noises and no movement…
So befuzzled as to what’s going on.

Basically there is no movement on the Z-axis at all. There is noise and no movement.
If I switch Z-axis with Y-axis (or X-axis) they will move. So it seems like a problem with the Z-axis stepper now? But with the old board the Z-axis stepper was fine and the 883 wouldn’t get stuck untill it tried to home the Y-axis.

Any tips for further progress?

(Cross posting this from my email to Cardbide)

Hi Stefan,

First thing to try would be to just re-flash the default settings to the controller. This could fix the problem if by chance your controller has the shapeoko settings (in which case the acceleration and steps/mm would be wrong).

We have a docs article on how to do it for Shapeoko.

The same directions apply for the Nomad except instead of ctrl+1, press ctrl+2.

Let us know if that makes a difference.

-Edward

Thanks Edward, tried that but not getting any output using ⌘+2.
⌘+1 gives me a nice log output in red but nothing for ⌘+2.

So it seems like I can’t reset to the Nomad settings.
I can only reset to Shapeoko settings. And I’ve now thus reset to Shapeoko settings and after a trying to do the homing same thing happens. Here is the output from the log:

Test Waiting... <Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.> ___________$0=10 ___________ ok ___________$0=10 ___________ ___________$1=255 ___________ ___________$2=0 ___________ ___________$3=1 ___________ ___________$4=0 ___________ ___________$5=0 ___________ ___________$6=0 ___________ ___________$10=255 ___________ ___________$11=.02 ___________ ___________$12=.01 ___________ ___________$13=0 ___________ ___________$14=1 ___________ ___________$20=0 ___________ ___________$21=1 ___________ ___________$22=1 ___________ ___________$23=0 ___________ ___________$24=100 ___________ ___________$25=1000 ___________ ___________$26=25 ___________ ___________$27=5 ___________ ___________$100=200.0 ___________ ___________$101=200.0 ___________ ___________$102=200.0 ___________ ___________$110=2600 ___________ ___________$111=2600 ___________ ___________$112=1270 ___________ ___________$120=270 ___________ ___________$121=270 ___________ ___________$122=270 ___________ ___________$130=250 ___________ ___________$131=250 ___________ ___________$132=100 ___________ <Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.> ___________SET MACHINE STATE: JOGGING___________ ___________SET MACHINE STATE: NEEDS_HOMING___________ ___________SET MACHINE STATE: HOMING___________ ___________gc_homing___________ ___________$h ___________ <Queue,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:1,RX:0,Ln:-1,F:0.> <Run,MPos:0.000,0.000,-0.310,WPos:0.000,0.000,-0.310,Buf:1,RX:0,Ln:-1,F:1000.> <Run,MPos:0.000,0.000,-3.605,WPos:0.000,0.000,-3.605,Buf:1,RX:0,Ln:-1,F:1000.>

Tried to do a bit more debugging and looks like I should try to reflash the GRBL into the motherboard. Is that right?

Also I seem to have pulled loose the blue wire in the X-axis plug. So I’ll be getting a new one of those tomorrow on the way into work. :frowning:

So good news! Got the Nomad to calibrate ok!

I received a new mother board (that’s the second one) and it installed easily (I’m getting good at this). And it’s calibrate the z, y, x perfectly. Except it get’s stuck on calibrating the z-height of the cutter.

It tells me “Machine parameters are invalid.”

Time for some more research.