Nomad 883 z axis issue

Have been using this Nomad all of a hour or so and the z axis is binding up.
Ran two, 10 minute test jobs. Was moving on to the 3rd and when homing the z axis is howling🤬
Was told this was a like new machine with 8 minutes on it.
Please tell me this is an easy fix/issue to resolve🤞
Hope I wasn’t sold a lemon as a “like new” machine :sleepy:

Do you mean the Z-axis was smashing itself into the top of the carriage and not stopping? Or was it just being loud when moving?

Not moving, in the middle of the carriage.
Sounds like some is preventing it from raising and lowering.
Sounds like there gear is jamed🤦‍♂️

Are you able to move it down (worst case with the machine powered off, by hand) and see if there’s something wrong with the screw or something?

It might need some lubrication, @WillAdams knows the particular brand that Carbide 3D recommends.


Haven’t tried that yet! Literally grab the threads and spin?
Was thinking about a full disassemble…
(If I HAVE to🤦‍♂️)
Z does look dirty
Have wd40 dry specialist spray

That might work but in theory they should be slippery. I just grab the Z carriage itself and pull it down.

A full disassembly shouldn’t be needed. I figure worst case you might have to take the bottom plate off so you can remove the carriage but I think even that will be unnecessary, the screw is probably just dry since it hasn’t been used (and therefore maintained) in quite a while.

It might also be a good idea to reach out to support and ask them what they recommend.


Hi Dan, glad to see you got the machine. That’s pretty weird, since that’s the sound of a stepper trying to turn, like I talked about in the email, but it’s not up against the limit switch. I wonder if the switch cable got jiggled loose in shipping and it thinks it’s at its limit. There’s an existing thread on here about steppers making a racket I thought I’d find for you. But going off memory, if you (turn the machine off) unweight the Z carriage by lifting up on it, while turning the lead screw with your other hand, you can raise and lower the Z by hand. Maybe put it all the way up til it hits the switch and lower it back down again, and center all the axes. To see that it can move freely without getting stuck on anything. The one job I ran on it while I owned it was about a 5min aluminum cutout, so maybe it’s a stray chip stopping up the works. Other than that, I haven’t actually spent much time on the machine so I’m not that familiar with what else it could be.

No you weren’t sold a lemon, it definitely did not do this when I made the video of it running in the ad.

…are those Z Axis wires getting kinked as the carriage travels to the right side of the X?


For lubrication see:

Check the wiring to see if anything is obviously misrouted or loose.

If you have difficulties which that doesn’t address contact us at and we’ll do our best to work through this with you.


Will try this when I get back from work!

If it was an aluminum chip would I be able to see it?
First two jobs ran fine :man_shrugging:
Going to try fixing after work :pensive:

Nick at Carbide and I had a video call yesterday. Extremely pleased with the customer service. Was a call center telecommunications administrator for 10 years and to say the least was very happy with the follow up!

No clear answer now as to what is going on.
We shall see what they say!:crossed_fingers:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.