Nomad3 GRBL Error: Pull off didnt clear/homing cycle failed

Please Help! I cannot get my Nomad 3 to initialize. I am getting a “GRBL Error: Homing Failed, Pull off didnt clear” also a " Homing Cycle Failed" error. I have tried powering down, manually moving axis, turn back on and I get the same errors. All Limit switches are working correctly. I have been talking to support, and it seems they cannot figure it out either. Please help I have barely used this thing 5 hours, if that, and had some projects that needed to be done before Christmas. If anyone has a solution it would be greatly appreciated. THANKS!

I dont have a Nomad but Shapeoko has many shared parts. Have you adjusted switches closer to trigger? The switches can work with metal object or by pushing mechanical switch but not close enough to trigger switch.

In addition to Guy’s comments, make sure that the limit switches haven’t slipped out of position, and also that none of them can move when pushed. Unfortunately, one of the switches (the Y axis) is underneath the machine, so you might need to turn it on its side to check the Y axis switch to make sure it is not flopping about.

I will give those a try! thanks for the reply!

carbide has sent me a replacement x axis switch after trying everything. Still didnt help. I will contact them tomorrow and see if there is anything else to be tried.

While you wait for an answer from support, you may try playing with the homing pull-off distance value, see if it changes anything (just a shot in the dark, but who knows)

Homing pull-off distance is GRBL parameter $27.
From Carbide Motion’s settings section, click the “Show Log” button and keep that log window open on the side. Then back in the main window go to the MDI tab, and send $$
You should see a list of $ parameters being dumped in the log window. Param $27 is probably 3 (homing pull-off distance in mm). For the sake of testing, you can temporarily change that value to something larger like 10mm, by send the following in the MDI command line


(you can check if the command was properly taken into account by sending $$ again and that the value of $27 was updated)

Then trying homing again.

If this all sounds too complicated, forget it, it’s just a hunch / way to move forward in the investigation while support addresses the problem for good.

1 Like

I don’t think folks should change the homing/pull off values — not sure how that interacts w/ the tool length sensor position — please check in w/ support first, and if you try it, have your hand near a kill switch in case it misses.

Fair point, and I can’t tell for sure either, sorry if this causes any confusion, support should be your primary contact anyway.

Had to send in for repair. They got it fixed. Although now i am having an issue with job files not listing tools that are used. When I hit start job in carbide motion, spindle will start without prompting to insert tool. Same thing happens mid job when you need to insert new tool. Spindle will rise but just continue to run without pausing for new tool change. This is getting frustrating.

Maybe the post processor selection in CC has been altered?
Worth double checking under Edit / Select postprocessor that the Carbide3d Nomad pp is selected?


Thanks for the quick reply! That was the fix for that problem. Thanks!

1 Like

Pull off parameters “shouldn’t” effect anything but pull off. Can be as little as required to bring switch back to NO, or more - maybe you want a little breathing room for unguided keyboard smashing. If pull off is set to say 10mm for xyz, machine position should be -10mm xyz.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.