Not carving right

When I start my file it starts carving correctly, then it does this hiccup thing and lifts off of teh board and carves above the board.

Anyone else have this problem or know what could be causing this?
Pleeeeeease help :frowning:

Are you able to share the c2d file from Carbide Create and the nc file that it generated? That would give us more to work from and figure out if it is something in the original file, the gcode or if the issue may be in the machine itself.

It happens with any file I create. I have removed and uploaded the newer version of carbide motion, turned the machine off/on, reset bit setter, etc.

I cannot upload the file I am using, as it says it is not a compatible file to upload. Suggestions?

One way to check things out is to use a gcode simulator such as

https://ncviewer.com/

or

https://camotics.org/

Which lets you see what the gcode / should / do on the machine.

Then you’ll know if it’s your toolpath or machine being funny.

1 Like

The tool path looks just fine in my preview on Vcarve, so I know the tool path should work fine. There are no issues when viewing it there.

1 Like

What type of Z axis are you running?

Does it make any funny noises before moving off the workpiece?

no funny noises, sounds normal. It does not touch board when running the cut path

Z axis?

I have a shapeoko XXL

1 Like

Is is the steel Z axis with the rubber belt driving it up and down, the Z-Plus with the leadscrew or the aluminium HDZ with the ballscrew drive?

ah, ok. It is the one with the belt, not the upgraded really nice one :frowning:

1 Like

OK, great.

The belt driven Z can lose steps going up and down for a few reasons.

After the error, if you return to X, Y, Z zero does the bit sit above the board by the same sort of height difference you see during the cutting?

If so then you may well be losing steps, the main causes of this on the belt driven Z are

  1. Aggressive plunges losing steps as the Z can’t apply enough force to the cutter to push down fast enough
  2. Insufficient belt tension allowing the stepper pulley to hop over teeth and lose position on the belt
  3. Stepper pulley grub-screws not tight and the pulley itself rotating on the motor shaft.
  1. I have not ever changed the plunge rate since I got the machine, so I don’t think that’s it
  2. possible
  3. the z axis has NO play in it at all. Tightened everything a bit ago.

How do I check the belt tension?

@Julien - is there a guide to setting Z tension you know of anywhere?

There’s some good info on general tensioning and pulley set screw slippage

https://docs.carbide3d.com/shapeoko-faq/shapeoko-3-how-to-check-the-pulley-set-screws/

The Z belt is tensioned by the tension screw pushing down on the tensioner bearing, there’s some good pics in the assembly guide here

Getting a screwdriver to the top of this screw is a bit of a pain, I recall being able to reach down between the Z fixed and moving plate when it was fully down with a long driver.

The video in this post has a good view of the hardware too

The belt should have a reasonable twang to it.

2 Likes

Not that I know of (beyond the install instructions).
It’s basically “adjust the tension screw until the belt twangs when pinched”

2 Likes

ok, I will try that. Fingers crossed :crossed_fingers:

Thank you

1 Like

If it happens again, re-check the Z zero after the event, that will tell us whether it’s the machine losing steps or something else going on.

Good luck

will do.

I use the bit setter, so I am not sure why it is miscalculating the z depth. Very frustrating.

I read your first post as “the job first proceeds correctly, initially carves to the correct depth, but then later it starts to be off along Z”. Is this correct, or do you have a wrong Z from the start of the job ?

both are correct lol I hadn’t used the router for weeks. Then I started it up, it began to carve just fine, then it goes offline on the z axis. when I ran the file through again, it no longer touched the wood on the initial pass. So, now…it does not even touch the wood on the first pass at all.

Can you try and upload your c2d file ? and/or the .nc file ?
I know you tried earlier, but using the upload button you should be able too, it does accept .c2d and .nc extensions so worth trying again ?

my file is saved as a gcode file…it won’t upload. I am not sure how to save it as the files you mentioned :woman_shrugging: