Odd Depth Issue

File attached.

The first 2 operations use the same bit. (1" bottom cleaning) First operation makes 1 large pocket, taking out 1/2". Second operation makes 3 pockets, starting at 1/2" and going to 1" and 1.25". However, the second operation only makes the pockets half as deep as it should. I first thought my Z belt was slipping. It’s not. (replaced the belt anyway)

Now, if I stop the project after the first operation, disable that operation and restart the project from the second operation, the pockets are cut to the proper depth. There’s been no bit change, no zero change, nothing.

If I just leave it to do it’s thing and finish without stopping, there’s a bit change (to 1/4") and the pockets get a little “finishing” work, again starting at 1/2" and going down to the same depth as the previous pockets. When it’s done, I end up with islands in the pockets since the 1/4" bit does the full pocket depth but the 1" bit doesn’t.

I don’t get it. :slight_smile:

cribbageboardbottom.c2d (255.0 KB)
cribbageboardbottom.nc (235.2 KB)

Not to sure if this means anything but the lower opening doesn’t share the same centerline along Y axis as the upper opening.

Oops. Good catch, thanks.

If I let the whole thing finish:

Then I run the program again, but disable everything except the 3 pockets. Again, nothing else has been touched. The results:

Is the M4 Z-axis tension bolt in place and secure?

You are starting the cuts at a depth of 0.495":

How is the space above that being cleared?

In place and very secure. Belt is tight. If it wasn’t, I’m pretty sure the issue would be with both bits. It wouldn’t be as consistent either; this happens exactly the same way, every time.

The cuts are starting at .495 because the 1st operation pockets out .5", then these pockets go deeper.

How are you setting the zero between bit changes?

I use a bitprobe, but there’s no bit change till after all the pockets get cut with the same 1" bit. The big board pocket gets cut (that cuts to the proper depth), then the center pocket for the pegs (too shallow), then the 2 pockets for the cards (too shallow). After that, there’s a bit change to finish up the pockets. (finger slots and the corners that the 1" didn’t get. Those are cut to the proper depth.).

Curiosity here I guess since your file looks okay to me. So once you switched to the 1/4in endmill and it pocketed to the proper depth. Did you then go back, disable the toolpaths, change back to the 1in bit, and then rerun?

In my mind I am wondering if you had the shank farther inserted during the first time using the 1in bit and not the second? I know my 1in bit is about 2/3 the length of the 1/4in endmill and if it is inserted to far the z axis would bottom out before it reached my spoilboard. If that was the case your z axis would have bottomed out not allowing it to cut the full depth. Maybe the second try it was farther out and allowed full depth.

My only thoughts.

Did you then go back, disable the toolpaths, change back to the 1in bit, and then rerun?

Yup. But then I ran the full project again immediately afterwards, with the bit untouched as the project starts with that bit, and I get the same results. I also tried stopping the program when it asked for the bit change, not change the bit, disabled the 1st operation (board pocket) and started again. That gets it all, so bottoming out isn’t the issue.

Those 3 pockets are all 1/4" too shallow, every time.

I think the NC file you posted only has the three pockets starting with the peg pocket. Can you post the nc file that included all pockets and cut incorrect?

1 Like

You’ve considered belt slippage, but how about tool slippage?

A 1" tool surfacing tool should probably do surfacing and not pocketing… Perhaps consider running the whole job with a 1/4" tool then running a surfacing operation after all the meat has been removed.

1 Like

My bad, it’s a 1" straight bit, not a flattening bit. As of today, there’s almost no doubt in my little mind that the issue is within the files.

I created a quick pocket job on some scrap oak using the same bit. 1st pocket from 0 to 1/2", second from .495" to 1". It cut both pockets to the correct depths. I then put in some maple and ran the same project as above. Somehow that got worse, only going down 1/4", and made me rethink the bit slipping idea. But then I ran the test again and both pockets were cut to the proper depth. There was virtually no difference between the 1st test and the 2nd; ~2 thousandths of an inch. I re-zeroed between the tests and the project, but didn’t touch anything else.

Also, the large board pocket is always cut to the proper depth. If the bit was slipping, I would expect that pocket to be too shallow as well.


Project file w/ all the pockets for this job enabled.
2 deck base.nc (324.9 KB)

There was a discussion on another thread recently about moving to 1/2” tools, which was discouraged. So I imagine 1” tools might also be discouraged:)

Can you redo the files and change the bit to a 1/4” and try that? That is, don’t use the 1” bit at all.

Immediately before the peg pocket starts there are two Z rapids, the first one barely up (G0Z-0.4902) from the bottom of the board pocket (G1Z-0.5000). The second 0.25 above zero (Z0.2500). It is as if Z zero is reset after that point but before prompt for spindle on, but I dont know why that would happen. It should not.

The lines are below:
6095 G0Z-0.4902
6096 Z0.2500 ’ Tool up 0.25 inches from zero , retract height
6097 (Peg.pocket.-.Pocket)
6098 M03S18000 ’ Turn on spindle
6099 X2.4083Y7.6157 ’ locate to start x,y for peg pocket
6100 G1Z-0.5450F8.0 ’ first Z plunge for peg pocket

Call me clueless…

Thanks for finding that, clueless! :grin:

I’ll just remake the file.

:roll_eyes: Ummmm…no. Not what i meant. The code shows no issue at all. From your description of the problem, it is as if a z zero reset occurred there. I recommend running the code you posted, that I already looked at. Zero before you start, start it, and watch it. Dont touch anything, dont pause anything, be an observer only. When it finishes the first two operations, then stop it if you want and report back how it worked. There is no reason I can see that the code should cause a problem. If you do remake the code, give it a unique name like “clueless”, run it, and post it with your new results.

Got it. Misread/understood what you wrote!

The file I posted should be the same one I last used, with the two tests. I stopped it before the 3rd pocket as it was clear the depth was off. I can start a new piece on Monday. I remade the file anyway and saved it with a different file name, but haven’t run it yet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.