Only Rough Cut, No Finish Pass

Hi, I can’t seem to get any combination of changes to do anything after the rough cut. Any suggestions?

@ignatius13, could you attach a screenshot of your Toolpath Parameters window please? And are you working from STL, DXF or bitmap input? I’m assuming this is MeshCAM…


Hey, thanks. It’s an STL.

@ignatius13, thanks for the screenshot. I don’t see anything wrong with your settings, other than there are mixed inch and mm units. MeshCAM, in my experience, really doesn’t like mixed units. (At least in the past–I’m so leery of them that I never use mm when I’ve already used inch, but that might not be a factor with version 6…) But I don’t think that’s a factor in the lack of finishing toolpaths. There really is only a roughing toolpath generated, or are there finishing toolpaths and they are just empty? What does your STL look like? Since you got a roughing toolpath the depth limit must be reasonable. I’m stumped at this point.


The finishing toolpaths (when I use both, or one) are there, so to speak when I run the program. I’m given prompts to change bits, but it’s at 100% and does nothing. When I uncheck “rough toolpath” in the save window there’s no visualization once the rough path disappears. It’s also definitely not an issue of the bit being too big to access all the areas after rough.

oh yeah…

@ignatius13, one more question–are you using 32-bit or 64-bit MeshCAM? If MeshCAM is stalling on calculating the finishing toolpaths that would make a difference. I had to move to 64-bit MC when I started using STL’s that were 40-60 MB.

Bonus question–why are you using keep-out areas when you already specified Machine geometry only?


I’m using MC6 build 26 on OS X. I don’t see 32 or 64bit. where would it be?

I added the keep out areas to protect the flip jig. It seems like the geometry would be based on the center of the bit and I didn’t want it gouging…

try reducing the tolerance to minimum
tbh i see no reason to not have it minimum at all times


I just tried creating a toolpath with no roughing operation and the path it generated had no tool paths and estimated time of zero.

I’m going to try and uninstalling it and reinstalling

1 Like

Well, that seems to have fixed it.

@ignatius13, I’m glad you solved it. I was out of guesses. BTW the 32- vs 64-bit is a Windows thing. I forget sometimes that MC also has a Mac version… :relaxed: