Playing with Fusion 360 - Zeros between tools

I am playing around with learning Fusion 360, and am having a little issue with the Tool changes. I know to post process the different tools separately. I assumed the zero point would remain consistent, but the router goes back to the origin and hits the limit switches at the end of the run, which I think shifts the zero reference. I have been digging around in the setup, is the home position for the axes in machine configuration where I need to change things so that it doesn’t go screaming off to find the limit switches? or is it hidden somewhere else?

Different files for different tools, while annoying doesn’t seem to be to bad to deal with, provided I can keep my zeros.


Shapeoko Pro XL, Carbide3D router

What post processor are you using?
Are you using G28?

I am using the Carbide 3D(Grbl) from the Fusion 360 POST library. Where do I find the G28?


Ok. I see that G28 is “g” code (duh!) So in the post processor set up, change that to clearance height?


1 Like

G28 can be set as a defined location for the machine to go. I bet your gcode has a G28 line at the beginning. When you haven’t explicitly set a G28 location, the default is machine zero, which is on your limit switches.
Just uncheck “Use G28” when you post (assuming that’s an option in your post processor)

1 Like

Yes, change it to clearance height and instead of homing at the end of each file the router will just lift up in Z. Although I don’t think rehoming should really shift your origin… I’ve found mine pretty reproducible but having it home for every tool change is a waste of time IMO

This topic was automatically closed after 10 days. New replies are no longer allowed.