Power button always on, does nothing?

Hi all, new to CNC and recently set up a Shapeoko 4. The main power button (blue LED) is always illuminated and seems to have no effect on the machine whether it’s set on or off. The machine seems to work (eg, jogging, have not yet tried cutting) regardless of what position the power button is in. The only way to power on/off the machine is with the red toggle switch inline with the main power brick. I’ve ensure all wiring connections are snug and have even tried plugging the 4-pin connector into the control board every which way. Any suggestions? Thank you!

When I assembled my Pro 4, I accidentally pinched the power wire when I installed the front right endplate, and like you, the only way I could turn it off was with the inline switch.

1 Like

Please let us know about this at support@carbide3d.com and we’ll work out how to handle it.

Will do, thank you. Will post the solution here when it gets figured out in case anyone else has the same issue.

My Pro XXL does the same thing. When I was talking to support about another issue I was told that was normal ??? Does not seem to affect operation but is confusing.

I would have told them that I do not need a night light. I want to look at my machine on the way out of my shop and know that it is off

1 Like

I had a similar thing happen to me on the Pro XXL but as its a similar setup this is what I did. It might be the connectors on the back of the power button touching the front bolt securing the aluminum beam/extrusion to the hybrid table. Its a fairly close fit in there so i removed the front plate with the power button and added electrical tape around the connectors/wires and bent a pin on the back of the connector ever so slightly to clear that bolt.

EDIT: Its been a while but if memory serves me well while the plate was off i may have also added a strip of electrical tape to the bolt passing through the right aluminum beam/extrusion as an added measure. Also in my case I seem to remember the button still worked as an on/off switch but the blue LED was always lit. Pretty sure its a 3 pin button (pwr, gnd, led) so i was probably shorting the pin to light up the led but in your case you may be shorting a different pin. Just guessing but might be worth investigating.

I have the same issue. I don’t see any wires pinched.
The blue power button seems to be stuck in the start position. It has no movement.

Anyone having difficulty w/ their power button (or any other aspect of the machine) should write in to support@carbide3d.com and let us know and we’ll do our best to work it out.

Update: thanks for everyone’s suggestions. Carbide Support suggested I try connecting the power button directly to the control board to see if the problem continued, and it did. That means the extension wiring between the power button and the control board was not the issue. They’re sending me a new control board… presumably they think there’s a short somewhere. Machine seems to be working fine otherwise. (Also, this is my second power button; the first one was stuck and could not be switched on/off).

I had a power button that was stuck, they sent me a replacement, that new one stuck. . .

What I did was not tighten the nut on the back side of the mounting plate, left it loose enough that the power button housing wiggles in the hole and then it would be able to press and depress. I only finger tightened the first time but for some reason that prevented it from working. Left it loose and success.

Based on other comments I looked further into the issue with my Pro XXL Power button being always lit and not doing anything.

I opened the panel and tried the button and it operated like normal. A little further investigating revealed a nick in the black wire. It must have been shorted to ground. I taped it and everything works normally now.

Now to see about extending the wire to outside the enclosure so I can shut down in an emergency.

Carbide ended up sending me a new panel, which has fixed the power button issue. Before they did, they had me try connecting the power button directly to the board (ie, without the extension wire). The issue persisted even after this. I did consider a wiring issue but could not see anything wrong with the wires or connections. So… new board it is!

1 Like

Carbide3d has excellent support. They are sending me a replacement switch even though I have basically fixed the issue.

Thank you guys!

2 Likes