Probing cycle failure

Hey guys,

Everything has been going pretty good minus probing errors after a bit change. Not every time, but enough to suck. Also when this happens it cancels my current job, which obviously isn’t ideal as all I can do is reload it and run it all again to that point while cutting air then hope the bit change doesn’t fail to probe again.

Is this a known issue with a fix? I will leave it failed this time in case you need a log or something to help.

It’s only day 4 for me with this maci, but minus these occasional errors I am loving this thing!

Please help lol

I guess I should email this to the help line as well.

Check your connectors. As you know the bit goes down and red light comes on, bit raises and comes down slowly until red lifgt comes on again setting zero for new bit.

Where does your failure happen on first plunge or second. Does your red light come on?

The machine has so long to trigger red light or you get a probe error.

2 Likes

I’ve never paid that much attention to the position values during the initialization sequence, but your zaxis has a max travel distance of 100mm and your CM screen shows it’s at -174mm from where it thinks zero is. Might not be a problem but it looks odd - I’ll have to check what my XL says when probing.

Thanks for the replies. Unfortunately my machine is still down. All the connections seem good, but when I initialize the machine it’s all good, then change bit then it goes to the bit setter, lowers down to the point of contact, makes a grinding noise and fails. Z is at -178.

I would suggest disabling the BitSetter, then contacting support@carbide3d.com and using the machine w/o the BitSetter until we can work out w/ you the issue w/ your BitSetter configuration.

One thing to check, make sure that if you have a bitzero, that the clip and the bitzero aren’t touching. If those are touching (e.g. electrical contact) the bitzero will also fail to probe

5 Likes

Thanks Will. I shut off the bit setter, but now my machine will not reach max depth on Z. When I lower it it stops about a half inch above the table. The machine is no longer grinding tho, so that’s a plus. I tried uploading a video of when it couldn’t reach the bit setter but couldn’t due to file type.

To confirm:

  • you’ve sent the correct configuration for your machine
  • you have a suitably long endmill installed
  • if the endmill is short you have a supplemental spoilboard

Thanks again Will. I reset the configuration to make sure it was correct.

I was able to re zero all axis off my work piece and am currently cutting a test run. Disabling bit setter appears to have worked for the time being.

Thanks for all your help. Hopefully I’ll hear back from support and can get a solution.

Figured out how to share a video.

In the beginning it would.reaxh the switch but not fully depress it. In other words it’s getting worse as in less distance of travel allowed.

Any chance you changed/adjusted the endmill stickout since then ? (longer endmill or larger stickout before ?)
It sounds like your Zaxis is reaching its bottom mechanical limit.

I actually only use this end mill and a 60 vee that sticks out even less.

But yes it is like It cannot go any lower. Also had once or twice where it ran too high. The limit was lit but it kept jamming up against it.

Both of these issues started yesterday before that I had no problems.

It is like the Z axis is too high, both high and low limit at times.

Got a good video, hopefully this explains the issue better. caught it in action. - YouTube

Thanks again for all your help. You guys are all great.

Looks like the end mill stick out is a bit short and your upper limit switch is loose

1 Like

looks like the end mill stick out needs increased.
It is close and thats why you have to trigger the switch manually, thing is, when you do that it has already lost z-steps and now raises too high and whacks the limit switch.
Give yourself a little more stick out with that end mill and it may work.
also, I am not sure, but in the first video it looks like you may be able to slide the router down in the spindle mount just a little more?
thinking a bit further on it, Are you sure that limit switch is mounted in the correct place?
The reason I ask is because I would think the machine would be designed so that it hit a solid place mechanically before it could actually harm the switch?
maybe not, idk…

1 Like

You are correct that I can lower the bit and it will “make” the switch this time… This is one scenario tho, as I also have the issue of it making this noise sometimes 1-2" above the button, this time I showed it was close, but it isn’t always anywhere near the button.

I can try to film it doing it with different heights.

I can try to film it doing it with different heights.

See @Ed.E 's reply above - your Z-axis limit switch is not properly attached. It’s loose and so the upper limit for Z travel is too high (and variable). The limit switch attaches with two hex head bolts. Turn the machine off, lower the carriage an inch or so, then position the switch and tighten into place. Then reinitialize.

As Ben reiterates, the Z Switch is the issue. I’ll just add that these switches are “proximity” switches and not contact switches. In operation, then should never actually touch anything, and certainly never be moved by anything.

I have lowered it all the way and retightened more then once. A loose switch is the result, not the cause. Hopefully Carbide contacts me today, I’m guessing the switch is bad. I get it is a proximity sensor, problem also is it senses (led turns on), yet doesn’t send signal to stop.

When the proximity switch’s light is on (say with a spanner near it), what shows as active in this panel?

It should look like my example and have GRBL Active Input Pins showing Z

4 Likes