Ramping Error Carbide Motion

Does anyone know why carbide motion is rapidly plunging down rather than following a programmed ramp move? It seems to rapidly plunge down and is also cutting deeper than programmed.

Please post the .c2d file, step-by-step notes on how you are securing your stock and setting zero relative to it, and how you are managing all tool changes.

Which version of Carbide Create and Motion are you using?

Also, are you using the .c2d file, or exporting G-code?

I am using Fusion360 to export the tool path and did not change tools between previous facing and adaptive operations. The previous operations worked great, and the issue wasn’t present. When I jog the machine to XYZ zero is in the correct position in the bottom-left corner, the same as in Fusion.

The stock is secured, and the bit is not slipping out of the collet. I just updated to carbide motion 579 from 575 and the issue is still present.

I switched from a ramp to a lead in and that helped smooth things out, but it is still cutting a .4mm deep slot when it should be .1mm deep.

I have attached the G-code for both files.
new ramp.nc (24.8 KB)
lead in contour.nc (42.3 KB)

1 Like

I just tried loading the G-code on a second computer running carbide motion and am still having the same issue.

I really need to get this working ASAP. Currently, cncjs seems to render the model fine, so I am going to look at using that as a stand in for right now. Does anyone have the macro for doing tool length offset?

Have you tried jogging over the stock at various points and making sure it’s actually held down flat, and a consistent distance from the spindle? A fraction of a mm is really not a lot, and sometimes materials can be warped or uneven to a degree greater than what you’re trying to cut. The safest method would be to machine the top surface so you’re guaranteed to know it’s flat and exactly where the CNC expects it to be.

The visualization in CM is not always a good gauge of what the toolpath will do exactly. If it behaves anything like Carbide Create’s preview does, it sometimes shows every other line of code. With arc commands, which Fusion uses in spades, you can get visual artifacts like what’s shown in the screenshots. The every-other-line thing is for performance of the visualizer, but rest assured your CNC will follow every actual line of code. Do you have a video of the fast plunge actually happening?

With your lead in contour nc file, your lead in feedrate is the same as the cutting feedrate. If you have a concern with this phase of the toolpath, you should set the lead-in feedrate lower than your cutting feedrate.


Okay Now I feel like a crazy person, I just re-ran the same program, and it went by smoothly… I guess the computer or the machine just needed a reboot? The stock was secured and flat, the images below are from before I re-ran the operation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.