Random disconnects


(F B) #1

I’ve been using my XXL more recently and can’t seem to get my most recent job to finish cutting. It has disco nected 3 times in different parts of the job. I’ve read lots of posts about people having this issue. My controller board is 2.4d. Relative humidity was around 40 percent in the shop.

I haven’t changed anything, so I’m wondering why it would have started today.

Some stuff I’ve tried
-different USB cable
-different USB port

  • cutting air
    – this is successful
    – I turned the router on and off several times during this to force a disconnect but it is fine.

My next step will be to plug the router into a known different circuit, but I’ve never had an issue before including other jobs in the last couple days.


(Dan Nelson) #2

What material are you cutting? Plastics always seem to make a bunch of static. There’s a ton of posts about this subject, which it sounds like you’ve already read. How is the power cord routed, out the opposite side of the machine from the drag chains? Any new dust collection added? Some folks have had luck by adding a ground wire to the router itself. If nothing has changed in your setup it’s a little strange that you’re now having issues. Sorry I can’t be of more help.

Dan


(F B) #3

Cutting Baltic birch plywood. No dust collection.

Power runs opposite drag train.

Once I separate circuits I’ll try the ground wire too. It seems like no one conclusively solved the issue with all these possible fixes.

I saw Will posted something about brushwear too which I might check, but I don’t think this router has 30 hours on it.


(F B) #4

Finally got some time on my machine again. I’m not sure, but i think the disconnects may have been linked to the x-axis being bound up.

When i tried to rapid position my machine the belt was slipping and it was blocked from moving on the x axis. The cord for my router had slipped in the zip ties and was pushing the drag chain in such a way that it couldn’t move. I don’t think this was happening during the job (but it may have been at such a low feed rate that i was missing it), but I finished the job last night without issue.

I think running the job in the air completed because the router power cord wasn’t stretched the same way.


(F B) #5

The machine worked fine the last couple times I used it, but multiple disconnects again last night. Definitely not being caused by the x-axis being blocked. I also tried separating the circuits that the router and the controller are on (nothing else is running) with no luck.

I figure trying @RichCournoyer’s method of spraying a little water before running a job to increase humidity might be worth a try. (however, it was 30 degrees out and raining, so I’m skeptical)

I’m also going to try a ground wire and see if that helps.


(William Adams) #6

Usually when the problem arises after a period of successful operation if it’s not humidity, then it’s the carbon brushes in the trim router wearing.


(Phil Thien) #7

When I had the older controller that was more prone to disconnects, I found that by wrapping one of those copper scrub brushes around the top, the disconnects were controlled. BUT, little bits of copper were falling into the router.

If I knew then what I know now, I’d first have wrapped a stocking or sock over the router, then the copper.

I think you’re right that worn brushes likely substantially contribute to disconnects. If you just look inside a universal motor with badly worn brushes, it is a bit of a sparky show going on in there.


(F B) #8

I’d estimate this router has less than 50 hours on it. I made huge mistake and ruined the router that came with my shapeoko.


(Phil Thien) #9

Some people are finding their brushes only last them thirty or so hours.

Seems like a typical failure mode, seems easy enough to eliminate as a source, just get a set on eBay and swap your brushes out and see if the problem clears-up.


(William Adams) #10

One consideration here seems to be if the machine is in a sealed enclosure — that seems to result in premature wear/failure.


(F B) #11

I just ordered brushes. Is there any stock in the usb isolator idea?


(Phil Thien) #12

Not with a 2.4d board, not in my opinion.


(Alvin Campbell) #13

This might not have anything to do with your issue but…I was using one of those little CNC 3018s from SainSmart and these disconnects would randomly happen. I figured it was just the tiny CNC at fault. My Shapeoko XXL delivered about two weeks ago. I finally got some time and got it all setup this past Saturday. I noticed that when I plugged it into my laptop…nothing. It would not connect. I found a forum or something that pointed me to the reset button and it connected. On this past Sunday I had a few disconnect problems, but I was able to make myself a wasteboard (thanks Ben at Myers Woodshop). I was trying to surface the wasteboard last night and I could not get it to remain connected long enough to even begin surfacing. Long story short, I narrowed it down to the USB ports on my laptop! I Franken-built another PC last night after all of that frustration and will give it another go tomorrow night.

The only commonality was my laptop. Check to make sure that all of your drivers and updates are current. Maybe even try a different PC if you have one available.

Alvin


(Alvin Campbell) #14

Well, I got a chance to connect my XXL to the Frankenbuilt PC and woohoo! No more disconnects. I was able to surface my new wasteboard without issue. It was definitely the USB ports on my laptop that was causing my disconnect problem.

Alvin


(F B) #15

I tried a job tonight and got a bunch of disconnects. It was 91% humidity, so that wasn’t it.

I checked my brushes. I’d say they have 85% or more life in them.

I then wrapped a copper wire around the aluminum spindle mount an wrapped the other end around nearby conduit. I ran about an hours worth of jobs after that without issue.


(F B) #16

That is interesting. I wonder if we will both continue to have success with our completely different solution to the problem. It seems like a weirdly common issue to have so many completely different solutions.


(mikep) #17

Using a powered USB hub between the laptop and the machine might help. There’s a redriver/switch in the hub that provides some isolation and redrive.


(Alvin Campbell) #18

It’s been about a week since connecting my XXL to a different PC. I’m happy to report that I’ve had no more disconnects. If all of the other suggestions fail, try a different PC. It could be a USB port issue.


(Phil Thien) #19

I will note that I use a USB Device Server, attached to the rear of my machine with stretchy hook and loop bands.

I don’t think I’ve ever experienced a disconnect with it, it allows me to use an insanely short USB cord (3’).

The one I’m using is a Silex and they aren’t inexpensive, but there are other brands out there.

With the one I’m using, I’m able to setup the software on my PC so it automatically connects to the S3 when the Gerbil is powered-up. The Silex I have has a second USB port so I have a wireless transceiver for my mini wireless keyboard/mouse I use for machine setup.


(Alvin Campbell) #20

Hey Baaja, I was wondering if your disconnects stopped? It’s been about four weeks now since I began using a different PC. I’ve not had any disconnects since I made the swap.