Random stops, CM 4.09 and Mac

Hi Guys

Is anyone else getting completely random stops in CM 4.09?

Im not getting an error, or a disconnect or anything thing else. The machine just stops exactly where it is.

The kill with still works, but the machine has to be powered off/on to make it respond again.

I’m running off my Mac as 4.09 is not working on my dedicated machine.



I saw that on 4.09 a couple of times, while jogging manually. I was trying 4.09 on both Mac and Windows (to see if that helped with the Arc Endpoint Error situation) and it happened on both.

We got our XXL and tried our first few jobs. One would complete and then one would go for about 15% and then just stop and sit there. Same symptoms as yours. Next two jobs, same thing. It just stopped moving somewhere along the job. No rhyme or reason.
Research showed us that it was really sensitive to power and data line fluctuations. We bought a 120V line conditioner and one for our USB port as well.
I’ve done 3 big jobs now with no problems. I may be something you want to explore.

1 Like

I used to get this a similar issued before going to a new version of the board. I have a feeling it might be something slightly simpler - my USB port on my Mac is usb c - I have to use an adapter and I think it’s not a solid connection. I wasn’t having the issue on my PC. Admittedly since I haven’t been able to run jobs on my PC recently I haven’t ran any jobs recently.

I did break down and buy a USB-A to USB-C cable when I got my Samsung Galaxy Book — still not wild about the idea of a machine w/ a fan close to the machines though.

1 Like

I’m just not keen on using a £1400 laptop next to a CNC mill… I can’t afford another :joy:

Thats why my mill machine is an salvaged windows machine

1 Like