Random Z axis setting sometimes

Help !! I’m having issues with my Z axis. Shapeoko 4 xxl, current CC and CM. Also the bitsetter.

Every now and then (seems random) the bit will start out high or sometimes low from where 0 was set. I go through all the initialize, load file, jog to 0, 0 and 0. About once in 3 or 4 times the Z axis is somehow off and the router either runs high or low. The bitsetter seems to be working. Files that have several bit changes don’t have a problem, unless on the initial pass. I’ve tried restarting the CNC for each project but no change. The high or low shift seems random. I don’t see any connection to previous settings.

Is there a way to check the Z setting after the jog to set 0’s? If I jog again CM simply seems to stop and I have to start all over again.

I’ve double checked my CC files and can’t find any problems. Running the same file twice can end up having different Z axis heights with everything else the same.

Am I missing something? Any ideas?

Please let us know about this at support@carbide3d.com — send us photos showing how the Z-axis motor is wired up and connected to the wiring extensions and at the controller — we’ll do our best to get this sorted out as quickly as we can.

In the jog screen there is a bottom “Rapid Positions”. There you can go to x and y zero and also for Z+6MM. Make a 6mm spacer and move to z+6 and slide the 6mm spacer under the bit and see if it is accurate. You could just jog to zero and see if it is on the surface or above or below. The 6mm spacer is safest because you are not likely to hit the project.

Another idea iz to make sure you’re always following the procedure:



Interesting. This sounds exactly like my problem. I suspect I may be guilty of changing a bit without being prompted. Even though I always jog and reset the Z axis before starting work It sounds like there could still be an issue. I’ll try being extra aware of bit changes and following the procedures outlined in the link. Thanks for the link.

1 Like

That sounds like it then. Even if you’ve reset the Z, it still thinks the last one is in and referencing on it.

1 Like

Josh - I think that’s it. I ran 6 or 8 things yesterday and no issues. I’m not sure I totally understand the whole Z axis resetting but bottom line is I now strictly follow the instructions on changing bits. Thanks for the help.

1 Like

The process does take some getting used to in order to make the machine happy. But once you get it, issues should be a thing of the past. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.