Replaced 2 limit switches New problem

Replaced 2 limit switches and worked well for about 3 minutes and I got error message GRBL ERROR UNKNOWN ERROR, Tried to reconnect and Error 2 CUTTER NOT FOUND
What now?

This means Carbide Motion can’t see the controller on the USB link: double check if maybe the USB connection got loose at the controller side when you went and installed the new limit switches? Do you have the blinky LEDs on the controller ?

1 Like

Thanks for that. The connections are tight. I will check the LED s

Serial port error. If you meant the lights under the XYZ connections, no they were not blinking. I switched to a tighter USB port on my computer. Same problem

No I meant the ones nearest the USB connector. Do you have any LED on at all?
Also do you hear the machine “click” /“thump” when you turn it on?

1 Like

Please contact us at and let us know the specifics and we’ll do our best to work through this with you.

The 3 lights on the extreme left are solid blue on the bottom blinking yellow in the center and blinking red on top.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.