Reversed inputs Shapeoko 4xxl

I’m relatively new to CNC. I had the most weird/impossible thing happen with my Shapeoko 4 XXL. All axis just reversed + for -.

I had homed it, zeroed it and started a cut. Then it did a z- move about -.150, it was programmed for -.015, yes I triple checked. Then I stopped the machine and homed it. I software disconnected it, reconnected and tried to run the homing. It slammed into the table.

I tried many things within g-sender, nothing worked. I downloaded and tried carbide motion and got the same result. I got it started without homing and did a manual z+ move, it went down, x+ it goes left, y+ it comes toward the operator. This machine was in operation normally just before all this. What the heck? Where do I start to try to fix it? Thank You

Is a homing switch or Probe input stuck?

What shows under Active Inputs on the Settings pane?

Please let us know at and we’ll do our best to sort this out w/ you.

Thank you, Fleming Valenzuela @ got me fixed up. A mix up on my part when describing the machine. What I thought was a 4xxl was in fact a 3xxl. once that was corrected in the software and firmware all is working well. Have a blessed day

1 Like