Ridges on pieces

Here is the information I was referring to above. I found it in the Wiki.


One pretty simple way but not as accurate and one more complex but should point you in the right direction.

A quick first pass at determining runout is to simply cut a slot and measure it and compare it to the endmill diameter.

Alternately, cut a 4" square out of the material in question, then measure both the square and the resulting hole — half the difference is the effective cutting width[2], less the endmill diameter is runout.


I have a dial indicator so I can rig something up.

1 Like

Alright so, this was setup with a .145 fake tool diameter for roughing and a .125 for final. There are some improvements but some weirdness.

It did just about eliminate the ridges on the interior pocket which is great (though, that won’t be seen in the finished box, sigh)

The 10ipm finishing pass actually caused the long grain sides to tear out and look poopy.

This surface didn’t even seem TOUCHED by the finishing pass.

And this is my favorite the left two sides clearly cleaned up, not perfectly but reasonably well, the opposite face untouched. I mean I get run out and such but I’m surprised with .01" it’s not making contact. Most likely scenario I would think is the router isn’t perpendicular to the cutting surface which I know was mentioned above. Unfortunately either the issue at hand or the process I’m using to do the finishing pass also seems to be leaving tear out on the piece that I can’t even fix with sanding, since a piece is missing

If anyone’s curious about looking at the file and seeing if I’m doing something boneheaded I don’t mind sharing it. I may go back to the default CC settings for the feed&speed just to see what happens. They’re super conservative but I’d like to get 2 boxes made for gifts then I can explore it more. I’ve had this on other projects so I need to find a solution, these are just the first where sanding it extensively isn’t an option.

hex ring box v5.c2d (761.5 KB)

Sorry for the flurry of replies. I decided to go down to my shop area and look things over without running the machine. Best I could tell with my machinist square the bit was running true, and figured I’d check in the morning by rigging up a dial indicator. However when I was checking things over I realized the whole gantry seemed to have more play than I’d expect, I could easily tilt it back to front. I gave the two lower eccentric nuts an 1/8th of a turn and it all became a lot stiffer and deflecting it at all takes a lot more force. I checked out some pine test cuts I did last week and while it’s less pronounced it’s there so I think tomorrow I’ll try just routing out some squares in pine and seeing if that made any difference.


Alright setup a 1" test square, it didn’t go all the way through so have to kind of look in the trough here but, my Kodiak bit after tightening the v-wheels:

About the same, noticable ridges and while the angle doesn’t show it it’s on both sides. Now the Kodiak bit is the second one I tried, the previous one was a cheapo (the 10 bits for about $10 variety) which were similar. But hey threw in a Carbide3D bit and …

hey wait a second, that’s a clean cut… I’ll be damned.


So at some point you ran the other bit too hard and bent it. It doesnt take much. Glad you figured it out. I wish there was a troubleshooting guide or flow chart but sometimes it is just trial and error.

Perhaps, they were brand new bits though in all 3 instances. Either way just did a test cut and had very minimal ridges show up and I think that was from an issue with the file that ran one part of it with too deep a cut. Hopefully that didn’t bend another bit :slight_smile: To be honest from what I saw the ridges stuck out not in, which isn’t how I’d expect an endmill to bend if under pressure but doesn’t matter. Redoing a bunch of stuff to skip the finishing pass and just run as a normal cut and then will try it in maple again.

It seems to me that if some bits are giving you a ridge and others not, that the bits giving you the ridge haven’t been machined perfectly straight, they have an (unintentional) profile where the D of the end of the bit (for instance) is a little proud.

1 Like

Yeah that’s what I’m thinking too. Took me awhile to get there because I thought I’d eliminated the bit issue by trying two different ones, but took till the 3rd to get a different result… I’m curious how the next attempt comes out.

Buy a good endmill and try it. I have had excellent luck with the Whiteside bits and they are not too expensive on Amazon.

1 Like

Thats nuts, to have to go over all that just to find it was 2 bits in a row.
I’d be going nuts too.
Good job.

Yeah, we should work up some sort of orderly troubleshooting guide.

Until then, added this to: https://www.shapeoko.com/wiki/index.php/Operation_Troubleshooting#Persistent_Ridges

Confirmed that this fixed it, added more workholding and tried it in maple and it came out fine, except for one minor blemish where a clamp got hit, it was out of the way of the bit but the collet hit it just enough leave a mark in the wood. I should be using more oversized pieces but I hate waste :slight_smile: . Also one tiny ridge you can see below on the left(bottom) piece on that first step down into the interior, but that was me having a .1 step down into a .125" deep hole, so now it will do that in one pass.


Excellent! (and agree w/ the waste aspect).

One comment on the clamping — for mechanical advantage you want the clamp to be elevated at the end which isn’t touching the workpiece and lowest where it touches the workpiece.


I’ve been playing with clamp shapes (super easy if you have a 3d printer). It’s not visible but the wider ones have ridges and I meant them explicitly for holding down the sacrificial ply but in general they should prevent lateral movement towards the clamp. The more traditional clamps that bridge between the two board have a notch so slightly more contact surface is in play and from above even when they’re angled up.

In this instance I didn’t go nuts because I’ve run this job like a dozen times with double stick tape and I only have once instance where it released a small piece early, so I was just supplementing that.


I really thought I had this handled.

What I don’t understand is it’s leaving the marks all the way around. If it left them on the left/right I could assume it’s not square on x, or y if it were only on top and bottom. But this seems equal all the way around.

Edit: it’s less pronounced on the horizontal x only movements but that’s also face grain and I’d expect a better result. Either way if it’s tilted in one direction I’d expect a groove on one side and a ridge on the other. I hate to toss another bit, I guess I can try it slower but these settings were more concervative than gwizard wanted.

How much is the tool sticking out? Looks like tool deflection perhaps?

I actually just got back from trying a little more. I slowed the feedrate to 20 (the pictures were at 35) and did a test cut, still got ridges, then I threw a brand new bit in there and ran it on the same settings, no ridges.

Now I’d concluded I borked another bit, but you’re mentioning deflection, and one thing that happened was I didn’t re-zero the Z axis between tests, there was not a lot of material left but the first cut was all the way through. Since they were both C3D bits that means the 2nd run wasn’t just a new bit but also held deeper in the collet.

So sounds like next time I have a chance I need to try the bit giving me issues but make sure it’s as far into the collet as it will go and run it at 20 again. That should eliminate one of the two theories at least.


I had a very similar problem and mine was caused simply by the router not being completely square to the bed forcing the bit just to be slightly cocked. This will cause the small ridges you are seeing. Took me awhile to find it and had to use a good tramming set but now my machine cuts straight down through 3/4 stock with no visible lines.