S3 stopping in middle of job

Hey all, I’ve started having a problem running jobs on my Shapeoko3. As it is running a job, it will just stop moving, requiring a soft reset to even cancel the job. When I try to run it again, it stops in the exact same place, so I don’t think it is necessarily an electrical noise problem. I’m using Fusion 360 to generate tool paths. I have used the carbide3d, grbl, and mach3 posts. I have used both Carbide Motion and UGS to send the g-code with the same result. On UGS when this happens, the machine enters a “queue” state. I’m really stuck on what is happening. Can anyone throw me a bone?

If it’s Fusion 360, and it’s repeatable, it’s probably the “Error 33”.

Do CAM in metric, rather than Imperial, and increase the precision by an additional decimal point. Please see:


Invalid arc format / calculation. — Increase precision to 5 decimals.[11][12] May be caused by stacked paths. Another possible cause (esp. if using AutoDesk Fusion 360) is inaccurate conversion from Imperial to metric — convert project to metric, then do CAM in metric, then send a metric G-code file to Grbl. Seems to be an accuracy or calculation problem.[13]

Unfortunately our page on this doesn’t mention this possibility, and arguable encourages it.

Well, after doing CAM in mm, altering a post processor in Fusion 360 (no small feat on a Mac-they really bury those .cps files), and having no luck, I tried running the code in check mode–and it was stopping because I exceeded my soft limit by 0.35mm. I changed my max z travel and now it’s running like a charm.