Selecting XXL in the dropdown doesn't work

  1. In Carbide Motion 4.0.416 the Machine Type is Shapeoko 3, and even if I change it to XXL in the dropdown and send configuration data it still says “Shapeoko 3” in the Machine Type. Never changes.

  2. When I select XXL in the dropdown and then calibrate and go on to run the job, the Start button won’t work. The calibration with the touch probe works fine but when I get done with that whole process the Start button won’t work and the job won’t run.

  3. When I select XXL, close the app, and reopen it, it’s back to Shapeoko 3.

  4. Version 4.16 crashes every time I use it. I’m back to 4.0 because I can’t use 4.16.

  5. I’m having a terrible time getting text in gcode from VCarve using a 60 degree vee bit to work. All I get is the lightest possible scratch in the stock. Doesn’t go in
    much at all. Dunno if that’s VCarve, Motion, or me. Prolly me, but I’m so frustrated. It’s acting like a drag bit, but I’ve set it up as a V-Carve job over and over. Pockets will work though. Just not V-carve. Note that this running VCarve on two different computers. The computer connected to the Shapeoko is a dedicated laptop. Nothing but Chrome and a fresh install of Windows 10 and Carbide Create/Motion.

I’m frustrated and I’ve just gotten started on this hobby.

Can anybody help?


First measure your V-bit to be sure it’s really 60°. Also, in Vectric products, the angle is the included angle, which is the angle of the full Vee. I believe Carbide Create is different and a 60° V-bit would be entered as 30°, so make sure you didn’t do that.

Second, what is the start depth of your toolpath in VCarve? It should be 0.0 and you will zero the point of the bit on the top surface of the work piece. Are you using a flat depth? If so, make sure it’s not too small. I’ve used 0.125" with good results.

Third, does your V-bit come to a sharp point or does it have a flat bottom? If it has a flat bottom you will need to compensate for that, but I can’t remember how right now because all of my V-bits have sharp tips.

Sorry if these are obvious things, but you should be able it to get to work. Maybe walk away from it for a while if you are frustrated, and then start the next day with a fresh outlook.

  1. That should be cosmetic — does the table size shown accurately reflect an XXL? Does rapid positioning allow you to move across the entire table?

  2. Confused by what you mean by “calibrate” here — I believe you mean homing? Please see:

  3. See above

  4. Please let us know the specifics of the crash — if it’s repeatable we’ll try to have a developer look into it. Please first check that your machine is fully up-to-date/patched and freshly rebooted

  5. This is usually caused by a disconnect in how you are specifying the origin in the file and setting zero relative to it. Please see: Vectric tutorial overview

If you have any questions or concerns, feel free to ask us at — I believe you’re pretty close, just need to resolve some terminology issues.

Yes I can confirm that VCarve uses the full angle not the side angle like CM. Also the width is the full width of the bit at the widest point, not the shank size for example.

Thanks for the reply and the suggestions. In order asked…

  1. I just measured it and it is indeed 60 degrees. I’ve got the tool built in Create as 30 degree and in VCarve as a 60 degree included angle.

  2. Start depth is 0.0 in VCarve and I’ve set up the job using the touch probe and then I’ve done it again by landing the bit on the surface of the stock and it zeros correctly. In VCarve I’ve tried V-Carving with the start depth 0 and the flat depth unchecked and it didn’t cut into the stock, so I started adding to the flat. On the same job I ran no flat, then .1, .2, .3., and .4. All of them only barely scratched the surface of the stock. If there was a difference it was too subtle for me to pick out.

  3. The bit comes to a sharp point.

Thanks again for the quick reply. I’m grateful for the input.

One more dumb question: are you using the Shapeoko post-processor in VCarve? I doubt there is much difference between that and the GRBL post-p, though. OK, two dumb questions: do the units of the design match the post-p units? (mm or inches)

I’m scratching my head over this one. I haven’t tried VCarve on my S3 XXL yet, but it has worked well on a small GRBL-based CNC I’ve been using for a while (v-carving in Aspire actually).

1 Like


Can you share your .crv file?
Upload a pic of the carve.

Thanks for the reply.

  1. Rapid positioning reflects the XXL. The first time I fired it up I had set it to XL and the rapid positioning didn’t use the entire table, so I understand what you’re asking. However, given the fact that it refuses to start when I have XXL set I was immediately suspicious that this error may have something to do with the stuff that I’m having problems with.

  2. Meant homing and zeroing. At the risk of using the wrong terminology, I meant everything that happens between connecting/loading the job and hitting start–homing, rapid positioning, painstakingly getting the cutter in place touching the corner of the stock or the touch probe, etc. When I’m ready to go and bring up the run screen, turn on the vacuum and the spindle and then finally hit “Start”, nothing happens. Pause and Stop are still grayed out and the Start button is ready to be pushed. The job is sitting there with the code not running and the progress bar unmoved.

  3. OK, but that means I’m going to have to reinstall the app so I can’t report anything right now. It’s a laptop less than a year old with nothing but VCarve, Create, Motion, and Chrome on it. I reinstalled Windows 10 a week ago and it’s all up to date. It’s dedicated to the Shapeoko.

  4. Not clear on what you’re asking. In VCarve my Z zero position is the material surface and the XY datum position is the southwest corner, and that’s where I’m zeroing Motion–at the material surface or on the touch probe, at the southwest corner.

1 Like

Yup. The VCarve post processor is [Shapeoko (inch) (*.gcode)] and my job is also in inches. If it would allow me to output direct to machine I’d certainly give that a shot, but it won’t. And that’s hardly a dumb question… :slight_smile:

As @neilferreri mentioned, sharing your .crv file would be the next step to help us solve your issue.

As an alternative, while it’s not quite directly to the machine, there is Vectric’s Vtransfer:

If you’ll let us know step-by-step:

  • what you did
  • what you expected
  • what actually happened

we’ll do our best to help you work through this.