Shapeoko 3 very loud when jogging Y axis

Hi, I have a very early Shapeoko 3. SN 23. It’s been a little while since I have used it. However, I was refreshing myself with the controls and functionality this afternoon, which was all going well. Although, I noticed that when jogging the y axis, and when running an air test combined xy moves and y moves are much, much louder than either z or x. It makes an almost resonant yelp sound. When jogging, the sound I am speaking really only happens when the axis is accelerating. Once it is up to speed, it seems to quiet down. I have checked and made sure everything is tight. Part of me is wondering if its always been this way,but wanted to see what others thought.
Appreciate the help!

It might be easier to see and hear what I am seeing and hearing. Would have had these available earlier, but YouTube decided to go down last night, :smile: Here’s a couple videos of the y axis. Let me know what you think.

SO3, Air Cutting, Loud Combined xy axis

SO3 Loud jogging y axis

Thanks for your help!

Can you tell if it is coming from one side or the other?
When the machine is off do you get any resistance or noise while moving the gantry by hand?

Hi Nathan, Thanks for the reply -

When the machine is off, I get some noise coupled with resistance if I move the gantry quickly, but this is to be expected as the back EMF from the steppers goes into the board.

It seems to be coming from the left side when viewed from the front, but its hard to tell.
I may need to take the gantry movement out of the equation, but then I would have to go through and re-calibrate for belt stretch. May be a good time to upgrade to gbrl 1.1 and CM 4 too.
I remember the machine always being kind of loud when moving, but this seems excessive. I’ve also looked at videos of others machines when doing the initial pen tests, and mine is much louder than those.

Thanks for any and all suggestions.

Are the set screws on the stepper motors belt gears tight?
If the machine is square and none of the V-wheels are dragging. I might look at the stepper motor on the side the noise is coming from, though I find it hard to believe it would seize up from sitting unused for a period of time…

1 Like

Hi Nathan,
Yes, everything is tight.
I installed my own aluminum bed and leveling feet. The leveling feet have nuts that hold the adjustment. The nuts were loose. This helped some, but the noise is still persistent.

I took the Y axis belts off and ran a job. The steppers are very quiet when jogging and running a job. When slow, they are a little louder.

I can move the gantry without the belts and the gantry rolls very nicely on the rails. Moving quickly/slowly, there is no sound similar to the sound produced when running.

I ran a job without the Y axis belts. There was some noise coming from the X motor/carriage, but a ton of vibration could be felt right at the pulley on the shaft whenever the y motors were running. Both sides.

It seems to be a resonance issue at certain speeds. I can jog fast and the machine is nice and quiet, but when jogging slow, it is really loud. The left does seem worse than the right.

Any thoughts?

I just ordered a set of 3 nema 23 vibration dampers. I am going to see if that will help transfer less vibration to the frame.

I am not super confident that the dampers will help though. Since it is only with the belts installed that the machine seems to resonate.

Any thoughts or insight would be really helpful!

So when the stepper motor is operating under a load, you have the vibration. Just a thought, do your leveling feet have rubber on them? If not, adding some might help reduce the sound.

It would be a bit of work, but you also could swap the motor in question with the Z-axis. I think you would be able to see if it is an issue with a stepper.

1 Like

The leveling feet have a polymer on the base, it is more plastic than rubber. I tried to put some cardboard under the feet yesterday to help dampen the feet further, it did not help. I also tried putting the machine on the concrete floor in my garage to the same effect. I can try rubber, but that will just help the transfer between the machine and the table. It doesn’t help with the actual machine vibrating due to whatever is causing it.

If it is a stepper issue, it would be all 4, they all seem to resonate to some degree. I wonder if it could potentially be due to an early control board not driving the steppers very efficiently?

The sound is not there with the belts disconnected, but with them connected it is. Therefore, it seems to me the vibrations are using the belts as mechanism to transfer the vibrations to the overall frame.

The vibration is so bad at low speeds it can be felt in the bed of the machine as well as the table the machine sits on. The vibration will cause a small piece of wood to propagate along the bed due to the oscillations. I don’t want to rule out my aluminum bed being a cause, but I have a hard time believing that to be an issue.

Please check your bearings and make sure that they all spin smoothly.

Please check your wiring and make sure all the connections are good and secure — if you have a multimeter check continuity.

I have verified that the bearings all spin smoothly. All V wheels spin nicely as well.
All the wiring connections seem secure as well as I can tell.
Could you please advise where I should be checking continuity.
Thanks again,

Hi David,
If you were betting, where do you think the noise is coming from?
What version of the Carbide board do you have? It could be a current issue with one of your Y motors.

Check continuity for each wire along as much of the length as you can.

Since it’s the Y-axis, it’s possible it’s one motor or stepper driver, but not the other — try swapping parts / connections around as described at: and see if you can determine which component is making the noise.

Let us know at and we’ll do our best to help you sort this out.

Hi @WillAdams

I sent an email to carbide support with the latest tests.
Thanks for your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

After quite a bit of troubleshooting and a lot of help from Brandon at Carbide 3D. Thanks Brandon! I figured out what was going on.
My machine for whatever reason had a steps/mm setting of around 20. instead of 40. I have an early machine, where you can select between 1/4 and 1/8 stepping. I’m not exactly sure how it happened, but after suggesting I play around with various settings in this arena, I determined that this was the culprit. Once I set it back to 1/8 microstepping with ~40 steps/mm, calibrated for belt stretch to further refine, the nasty sounds went away.
Maybe this can help someone in the future.