Shapeoko 3 XXL Communication Issues with Older Macbook Pro

I’ve setup my new Shapeoko 3 XXL and really like the machine. However, there seems to be disconnect/freeze issues frequently when running from my Macbook Pro (OSX 10.11.6, el Capitan). The point at which the machine stops seems somewhat random, so it’s not a particular G-Code error. I’ve been able to reproduce the issue in bCNC so I don’t think it’s specific to Carbide Motion (more likely the control board or a serial/protocol bug).

The issue occurs without the router running, so it’s not the on/off noise that seems to have been reported a few months back (and is hopefully taken care of by the new boards!).

Essentially, the machine runs fine for a short while (between a few seconds and a couple of minutes) and then stops performing the specified instructions. From the terminal is appears to still be up and running (sending back “idle” commands every second or so), but the machine’s motion freezes and further communication seems to not work until the board is reset (or sometimes pausing/replaying seems to snap it out of its idle/frozen state).

My guess is that this is somehow related to the serial driver itself, since I’ve tested on another Macbook Pro that is a few years newer and the problem seems less frequent (but still present). Some ideas:

  • Maybe it’s baudrate timing related and a command is being dropped?
  • Maybe there’s a watchdog/heartbeat command that isn’t being acknowledged in the driver and this causes the machine to go into an idle state?
  • Maybe the GRBL board needs reprogrammed? The machine wouldn’t run/jog/home until I manually set the homing settings to true ($22=1 in grbl); makes me wonder if my board wasn’t fully programmed…

Any thoughts/suggestions would be greatly appreciated. Thanks!

Hey Adam-

Send an email to support@carbide3d.com and we’ll get it taken care of.

-Rob

Just wanting to post an update after working through this over the past few weeks.

The Shapeoko support staff has been incredible. They immediately sent out a new version of the controller board for me to try out and verify if the problem was with the board itself or something else.

Unfortunately, in my case it wasn’t the controller that was causing communication issues. It seems that something on the MacbookPro driver (I tested on two models, one from 2007 and one from 2011) was the issue. Watching the serial communication stream in, you could even occasionally see misaligned/broken status info.

So I hooked up an old linux computer (from 2005) and the communication seems to work perfectly. Hopefully the Mac issue can be addressed in the future, but for now, I’d suggest running on Linux/xubuntu (or Windows if you must) for reliable communication with the machine.

Hope that helps others who may be running into similar issues on a Mac/OSX setup with their Shapeoko!

Cheers,
Adam

P.S. For anyone just setting up a new control board on a machine with limit switches, make sure you set $20=1, $21=1, and $22=1 to enable limits and homing. Also set $130, $131, and $132 to your respective X,Y, and Z table size.

1 Like

Pls someone help anser me my SO3 XXL what is the value to set for $130 & $131 ---- Do I need to set $20 -$21 - $22 = 1

plse help me.
I also change the setting to use MM instaed of inches in carbide created, then generate the gcode - I am going to try again and pray that it will work.

I would suggest

$20=0 (soft limits, bool)
$21=0 (hard limits, bool)

that way the machine shouldn’t error out

Based on the last time I checked, changing from Imperial to metric won’t alter how Carbide Create writes out G-Code — it always uses metric.

Thanks Williams - I am setting them back to imperial-inches and leave $20=0 & $21=0 and give it another try - God help me I pray

Hi Williams - pls tell me $130=838 & $131=485.8 for my SO3 XXL is this correct???

Those numbers seem more appropriate for an XL.

Per: http://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/

they should be

For XXL Shapeoko machines the Table Dimensions should be set to 850 X and 850 Y

Explian this someone, I wonder if the creators of shapeoko and the carbide controller know what they are doing. Hi Williams out of frustration and waiting for the part to ship from you that hopefully will resolve my issues which you blaming on the use of the water spindel which causing the EMI which brake the connection, also told me I have to use different outlets and surge protectors and I plugged them on difference outlets these are all done - I test again just a few munites ago I went to set on CC to use MM instead of inches just to see and save the gcode, even thought you told me here to use Imperial - well this thime it cutted with my water spindel on and it goes to 39% of the job, nver went this far for the last 9 days after upgrade to CM4/GRBL 1.1 - Now rolled backup to CM3/GRBL 3.0.361 (tried also 366 - 368) none work -
well it stop and said ‘Lost connection with com port’ - This is bad for shapeoko as newbies will not purchase this cnc brand for all the issues and bugs which are not able to resolve, should not blame on EMI - should research and go over logic and trouble shoot so people can have hope - I am running out of option and do not know what to do now for my business as I can not use the SO3 at all