Shapeoko 3XLL disconnects (not just dust collection)

So ive been dealing with disconnects for nearly 2 years using the shapeoko. If i use pine i am fine but if i use something like cedar or mdf i get disconnects, I have since grounded my dust collection and i can manage the dust collection disconnects but the problem im really concerned about is my disconnects when the system isnt even in use.

Right now if i have no jobs running and the machine is sitting by its self and i use my sanders or compressor or miter or table saw there is a chance my machine disconnects in the other room. Ive stopped working in the shop when the machine is running to minimize this but i have no idea how to tackle this problem.

This sounds like interference coming over the power lines. Are all these machines on the same circuit, i.e. controlled by the same circuit-breaker?


I don’t see an open ticket on this — please write in to and let us know of your difficulties and we will do our best to work through this with you.

This sounds like a potential improper grounding of the shop outlets? Weird things happen when power systems float around…

Or maybe the power supply of your S3 is about to kick the can in a puff of magic blue smoke.

1 Like

If you like a simple tester for the outlets, something like this will tell you if the lines are all connected:


They should ideally be on separate circuts. Any idea how i could go about heling to filter the interference?

I didnt submit a ticket for this as the last 2 times it was not able to be resolved. The last time i talked to someone they suggested i buy ESD mats to put under my machine but i couldnt find anything under 500$ Canadian.

I did this just the other day because i wanted to confirm that my grounding of the dust collection worked. All of my outlets are correctly grounded.

1 Like

Some people have had luck with surge protectors, but it’s hit-and-miss, I suppose depending on exactly how the manufacturer designs things. Ferrite chokes can help as well, you can get ‘add-on’ chokes you could apply to your existing power cords:

1 Like

My original SO3 XXL had disconnects. The problem with mine was the original controller had a flakey usb connection where the usb cable plugged in. I solved it by putting a wire tie holder that has adhesive and wire tied the usb cable so it had a straight shot into the controller so it did not hang by its own weight. That solved my disconnect problems. I eventually replaced the original board and keep as a spare because I wanted a BitRunner and the original boards did not have the connector for the BitRunner.

If it is noise from the circuits that can be hard to diagnose without an o-scope. However those cheap little circuit testers can help if your polarity is reversed or there is not real ground.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.