Shapeoko 4 Homing Issue

After initiating homing, the router assembly starts moves up then hits the top of the X/Z assembly beneath the Z axis stepper motor, pushing the Z proximity switch up. The router tries to keep moving up then stops a few seconds later and produces the following error in Carbide Motion:

“GRBL Alarm 9:
Homing fail. Could not find limit switch within search distances.”

The Z proximity switch is working as it turns red when I place anything metallic beneath.

Any help would be appreciated.

Please contact us at

First thing to do is to power up, connect to the machine, go to Settings, then test the Z-axis homing switch — does it register as the Z-axis under Active Inputs?

i’ve just had a similar issue. ensure that it is the CORRECT sensor reading on the screen when you are testing them.
I just had to get a harness replaced as I had crossed wires in mine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.