Shapeoko 4 XXL runs into LY

I just finished setting up my Shapeoko 4 XXL and having some issues initializing the machine for the first time. triple checked all connections. Pushed 4 software, running newest 537 software which says has support for this machine. Set defaults for Shapeoko 4 XXL. Limit switches light up when putting metal in front. The thing is when it starts to initialize it jogs to back left corner where there is no limit switch and it goes until i shut it off. I feel like it should try to go right to the homing switch to find it. It raises the motor and finds the Z limit switch and stops and if i push the gantry back to the far right before i start machine it hits the limit but still shoots over to the left. I felt like it may have been the YL and YR were backwards but tried that and still not working. Please Help i want to start using machine. Tried to call support didnt get anywhere just left voicemail.

What’s your $3 setting?
If it’s odd, subtract one. If it’s even or zero, add one.

Edit: Check in with support first. As @WillAdams says below, your wires are probably in a non-standard order. My suggestion above will work if that’s the issue, but they’ll want to send you the right harness.

If YL and YR were backwards the machine would home at the right front corner.

Homing at the back left corner is caused by the X-axis being reversed.

Please contact support@carbide3d.com and send them photos showing how your motor is connected to the wiring extension and your wiring extensions to each other and the controller and we’ll do our best to sort this out with you.

While changing the Grbl defaults will work, we want folks to have a standard machine/wiring so that the defaults will result in correct operation.

1 Like

I’m a noob to cnc so how do I find out $3 setting?

Settings–>Show log

Back to MDI, enter $$ to see settings.
Send $3= (new value) to set new value.

If your $3 value is 0, send $3=1

Note: I rarely use Motion and I’m probably way behind on versions. Not sure if anything has moved.

It appears my cable is terminated wrong for the X motor. After working with support they confirmed. We swapped cables a couple different ways and tested. They are sending me another cable. This is why I went with shapeoko from hearing about how good support was. Got a call within an hour or so. I’ll update post for everyone else if this fixes issue. Thanks.

5 Likes

Changing the cable cleared up the issue for anyone that runs into this in the future.

3 Likes