Shapeoko 5 Pro - Over travel

According to the spec for my machine (2X2), the travel in X & Y is 24.53".
The spindle was directed to travel 25.25" from front edge (face of t-slot extrusions) toward the back in Y+.
The gantry ‘crashed’ creating a loud bang, which resulted in Y-axis location being off by about .125" (I would expect it to be off by around .75"?).
Are these machines resilient enough to withstand such an event multiple times?
Do I need to be concerned about possible damage to the motor/ballscrew nut/etc?
Why would it not alarm out when detecting travel limit?

Has anyone experienced this before? Hoping that no damage was done and a way to prevent this in the future.

Toolpaths created in Solidworks/HSMWorks w/ Carbide3D post processor and Carbide Motion control.
Stock Shapeoko 5 Pro with no mods to machine, control/processor settings. The machine has always initialized and homed successfully.

There’s a bit of overhang even if one doesn’t use “gantry shift for joinery”.

Yes, they are quite tough — we won’t discuss how many times or how often or how badly I’ve crashed mine.

What happens is the motor tries to keep moving thing, can’t, and generates a bit of heat — so long as one doesn’t leave it grinding in place so that things overheat/burn out, it should be fine.

Thanks for your quick reply and putting my mind at ease!
Any way I can prevent this from happening? It’s somewhat concerning that the limit switches don’t detect/notify.

The switches are for homing, and are not enabled as limit switches.

To keep it from happening make note of where the origin falls relative to the structure of the machine and how it can move — if I’m doing a job which will be close to the limits I:

  • position my stock and set origin relative to it
  • jog to the furthest extents of the stock plus the radius of the tool if cutting outside of it, plus 10% of the tool radius as a margin for error

If that fits, I proceed w/ setting up the file — if it doesn’t, I shut things down and work out how I’m going to tile the job when I set up toolpaths.

Good to know that limit switches are not enabled while running.
Sounds like I’ll just need to be more careful in my setups and keep the spindle well within the travel window.
Thanks for your clarification and suggestions!

I’m with @WillAdams in that I’ve crashed Shapeokos more times than I care to admit. So far in 7 years, I haven’t damaged one by over-traveling.

3 Likes

Could I enable the GRBL setting for hard limits ($21=1) to immediately stop travel and alarm out when the limit switch is triggered?

Yes, but that’s not a supported configuration, and it’s not that helpful if you don’t have switches at each end, and since the wiring isn’t shielded false positives could be an issue, and in our experience, it resulted in hard to troubleshoot issues.

1 Like

Thanks for the explanation! I am just starting to learn more about grbl and figured I’d ask but knowing it probably wouldn’t be that simple :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.