Shapeoko Homing Timeout?

Does anyone know if there is a timeout setting for homing? I have an XXL and if my x or y is far from the home position, homing doesn’t complete. Carbide Motion still says “Homing”, but it just stops. If I kill CM, restart, and home again, it will complete. It seems like it’s some sort of timeout setting but I’m not sure.

1 Like

You need to set your table size in the max travel settings.

$130=800.100 (x max travel, mm)
$131=838.000 (y max travel, mm)


It happens to my Shapeoko 3 XL machine as well
Under Settings my

X is set to 850
Y is set to 430

I’m not sure that is correct. The published working travel is 33in x 33in or 838mm x 838mm. I think the documentation presented by carbide3d is not correct. They state you should enter 850 in both $130 and $131. However, I crash in x if I do this. Y is fine. I’ve emailed support and asked for clarification on the these settings. I’m still not sure though if this answers the question if there is some sort of timeout in either carbide motion or grbl.

1 Like

I homed mine, then jogged it over in each direction until it was almost touching the switch at the other end, then used the number of steps I jogged to get the max travel setting. I can’t remember why I used 800 for my X, but I have had zero homing issues since, regardless of where I start. but I usually manually jog it back to clear clamps and other obstacles before I hit the home button.

1 Like