ShapeOko origin point

Whenever I home my ShapeOko 3 in Carbide Motion, it immediately moves to spot in the upper right quadrant. Not all the way in the back corner, near the halfway diagonal from the center point to the back corner (but not exactly). I’m assuming somewhere there is a machine position that is stuck in memory somewhere that tells the ShapeOko where to go after homing, but I can’t find this setting or figure out how to change it.

(Note, this may have nothing to do with Carbide Motion. I haven’t tried homing it in Universal G-Code Sender or bCNC or any other programs.)

Very much appreciate any suggestions. Thanks.