Shapeoko Pro X axis backwards

I got my Pro all set up and went to initialize and the x axis is trying to home to the left instead of the right (towards the limit switch). I’m assuming the stepper motors power is backwards, but how do I fix it?

Rather than rewire the motor, I would suggest changing Grbl — this would then be easily undone.

Add or subtract one from the setting for $3

Go to the Settings pane, open the Log, go to the MDI, send $$, then check what is set for $3 — if it is odd, subtract one, if it is even, add 1, then send that changed number as, say it was 6:


When I open the log there is nothing there. the x axis is all the way to the left and cant go any more. Do I need to let it keep going until it gives an error? It sounds like it may hurt the stepper motor

Okay, I found where it says $3=6 but how do I change it to 7?

in the mdi, just type $3=7


That worked! Thank you!

My new problem is my z wont go down past an inch. Any clue? I can jog up and down but only at the top inch. The machine is set to shapeoko pro xxl and 100mm for z

Glad to hear it!

Congratulations on having the first assembled machine in the wild!

For other folks, @wmoy just dropped:


William, do you have any insight as to why I can only go down an inch in z?

What do you have set for Travel Distance under Settings?

What about steps/mm for $102?

In the settings page its set at 100mm. I guess im not sure how to check $102, there isnt anything in the log after initializing

Check to make sure Z+ settings are flashed to the controller. If you don’t, the default is 40 steps/mm as shipped from the factory. Needs to be changed in the long run as belt Z is no longer a thing.


How do I do that? Im completely new to shapeoko!

Please see:

As @wmoy noted you are probably set up for a belt drive

1 Like

I see. When I select load defaults I choose my machine, but it doesnt prompt to set the z axis type. Should I try the regular shapeoko xxl?

Which version of Carbide Motion are you using?

CM517 or later should so prompt.

I got the z axis moving but now its axis is backwards

Please check all the wiring for the Z-axis — is it consistent with the other wiring?

I got everything working and ran the hello world test! I’m not sure why z went backwards but now everything is working correctly. Thanks for all the help!


Prove it! :wink:
We want to see a pic of the first one!