Shapeoko went nuts!

Hi guys, I’m looking for some help.

My shapeoko went bonkers when cutting some Ali today - it started grinding too hard too fast - lucky I think I stopped it in time to save any real damage to the machine - (same can’t be said about my new clamps or bed. Few bolts came loose in the explosion of power when it burst through the top of the model

Here is the file I’m working in within fusion 360

http://a360.co/2lGD1cB

It got around 90% before going bonkers and cutting the Y axis too far. I’m sure this is a user error but I’m not sure what I did wrong?

any advice would be helpful.

Possibilities include:

  • error in G-code
  • lost steps
  • skipped belt tooth
  • loose pulley set screw
  • loose belt

Of all those, only the first can be checked in advance — what did the preview look like?

and the last two can be diagnosed afterwards — but unless the belt gets damaged, you can’t tell that it skipped a belt tooth, and while I believe that the motors can be damaged by being forced to loose steps internally, that’s all but impossible on a Shapeoko due to the belt drive.

Unfortunately, the way that the Shapeoko achieves the price point that it does is to set up everything so that there’s a reasonable confidence that every step before it will execute correctly — the problem is, any such mis-steps are cumulative and can cause serious problems.

I really wish there was an affordable option for positional encoding as the LoboCNC had, or some other alternative which would be a similar game changer, but the only one which seems promising (using a set of inexpensive digital calipers as a D.R.O.) is speed-limited to a degree which doesn’t make sense for a belt drive system, and requires pretty much an all-new electronics stack.

1 Like

Thanks for coming back,

I can’t see anything wrong with the shapeoko it’s self - I t was screwey a couple of times after the crash but overall looks ok. I’m sure there is an issue with the program, but there must be thousands of lines - so I’m not sure where the issue lies… if it’s a setup of parapamters - i.e. there was too steep overlap or if the program didn’t compensate for stock to be where it was - when it burst through it skipped then it all went Pete tong…

List of previewers here:

http://www.shapeoko.com/wiki/index.php/Previewing_G-Code

Another option is to cut the file in foam or machinist’s wax first — that may reveal certain infelicities in the paths.

1 Like

Have you protected the electronics from aluminum chips? If the chips get on the electronics board it can cause all kinds of mayhem.

1 Like

yeh, I built a surround a while back

I won’t have time to look at the Fusion CAM settings for a bit, but a guess of where to look is at the lead-out at the end of an op. For example, if you do a 2D contour to cut out a piece (nice BTW due to tabs) and you only do once around (instead of a wider multipass per depth) the default leadout at the bottom will try to cut full depth of the material because apparently it doesn’t consider it might still be in uncut stock.

2 Likes

I thin you are right - I’m just not quite sure what the lead out was for.

I repeated the project yesterday but did a contour around it first and it seemed fine. Unfortunately I damaged my ball nose bit the first time so the project is now on hold.

Lead out is an attempt to reduce tooling marks by moving the cutter away from the part before retracting. But it means you need a channel that is at least the tool diameter plus lead out distance around the part. I often just turn it and lead in off because of this.

1 Like

I’m just looking at the lead out settings and it’s only 0.635mm - I don’t feel thats very much.

Non engagement feed rate was far too high and that will have caused some issues on this design.

Hey @Luke I took a look at the file. So the lead in/lead out was an issue. It was telling it to cut stock that was there, but because Fusion did not know about it it will attempt to link lead in there. It does this to make runs faster.

If you expand the stock and choose the model box point option you can get better results from the 3D adaptive toolpath, while still maintaining the start point you originally wanted (I think I selected the correct corner).

Here is my version: http://a360.co/2kv3WXZ

Look at Edit setup for more detail.

You may want to add in tabs for the contour. Perhaps playing with some of the other options will result in a quicker run time. The first setting I always adjust is the helical ramp clearance.

Best of Luck and Happy Milling :slight_smile:

4 Likes

nice one, thank you - will be using this advice going forward